Bug 1570405 - Touchpad lags every few seconds in wayland with libinput (problem not present with synaptics in X)
Summary: Touchpad lags every few seconds in wayland with libinput (problem not present...
Keywords:
Status: CLOSED DUPLICATE of bug 1364850
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-libinput
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-22 15:45 UTC by Mihajlo Milenovic
Modified: 2018-08-31 06:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-31 06:13:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Mihajlo Milenovic 2018-04-22 15:45:03 UTC
Description of problem: On T460p laptop, if you move circularly with your finger cursor will stop every few seconds. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Enter Wayland on T460p
2.Circle your finger on the touchpad
3. observe how cursor stops every few seconds. 

Actual results:  cursor choppy


Expected results:  cursor should move without interruption


Additional info: This does not happen with synaptics-legacy and x11. Therefore problem is not hardware.

Comment 1 Peter Hutterer 2018-04-23 00:15:41 UTC
Please attach an evemu-record of such a sequence and *at the same time* run libinput debug-events --verbose --enable-tap (the latter flag only if you have tapping enabled). Attach both output files here, thanks.

https://wayland.freedesktop.org/libinput/doc/latest/reporting_bugs.html

Comment 2 Mihajlo Milenovic 2018-05-07 11:26:38 UTC
It seems this, along with other bug (resume from hibernate/sleep stops touchpad from working) happens only when CSM is disabled and BIOS set to UEFI only. I have enabled CSM and now everything works fine. Will play with BIOS options when have time and will send requested info. Just can't right now.

Comment 3 Peter Hutterer 2018-08-31 04:23:32 UTC
Out of interest, did you ever find out anything more here? Or was that one change all it took?

Comment 4 Peter Hutterer 2018-08-31 05:28:07 UTC
got my hands on a t460s and while I can reproduce it, the BIOS settings don't seem to have noticeable differences. Unfortunately, I only had access to the device for about 10 min, so I couldn't install and debug further.

This was a RHEL7 machine with libinput but X, not wayland.

Given that you say it doesn't happen with synaptics, I'll need an evemu-recording of an event sequence that reproduces it please so I can debug this further on my machine.

Comment 5 Peter Hutterer 2018-08-31 06:13:30 UTC
*facepalm*

I just realised - this is just Bug 1364850. Nothing to do with the bios, it's the same generation hardware where the trackpoint sends the occasional x/y event while you're using the touchpad. This triggers palm detection in libinput and is the cause for the 1s pause. That explains why synaptics works, it doesn't have that palm detection code.

*** This bug has been marked as a duplicate of bug 1364850 ***


Note You need to log in before you can comment on or make changes to this bug.