Bug 1570424 - [Docs] Scaling large environments - setting pool connection and database connection settings for large environments
Summary: [Docs] Scaling large environments - setting pool connection and database conn...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.7
: ---
Assignee: Rolfe Dlugy-Hegwer
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1347644
TreeView+ depends on / blocked
 
Reported: 2018-04-22 19:36 UTC by mlehrer
Modified: 2019-10-25 15:42 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-25 15:33:07 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description mlehrer 2018-04-22 19:36:11 UTC
Description of problem:

There is a need to document necessary tuning changes to the connection pool and db connection settings for large RHV deployments with moderate amount of hosts and user concurrency. 

#Problem:
Default connection pool and max_connection settings will become saturated in large RHV deployments.
Several times in the past it was seen in large environments with many hosts, that users may receive 'Unable to get managed connection for java:/ENGINEDataSource' in the /var/log/ovirt-engine/engine.log.

#The effects of this issue presents in several different scenarios at scale such as: 

1) 'mass outages' where the engine needs to re-establish connection with hosts, users will notice the overall enviroment appears 'slow/sluggish' and some hosts may remain in non responsive state.

2) sluggish UI for the webadmin on the engine and then overtime eventual inability to log in to the webadmin [1].

3) noticeable delays in loading initial webadmin logon page after service ovirt-engine restart.



Version-Release number of selected component (if applicable):
4.2

How reproducible:
Very

Steps to Reproduce:
1. Setup env with 100 hosts or more # much easier to reproduce with 200.
2. Activate Hosts concurrently from UI
3. Connection pool usage will increase, and eventually become saturated once additional hosts, or concurrency is involved at default connection pool and db connection settings.

Actual results:
Receive 'Unable to get managed connection for java:/ENGINEDataSource'
Connection pool saturation on engine.

Expected results:
Normal operation without exception or sluggish behavior due to connection pool saturation.


Additional info:

Comment 3 Yaniv Kaul 2018-05-30 14:53:21 UTC
Ping?

Comment 5 Daniel Gur 2019-03-19 10:53:54 UTC
I think this is already documented by Avital here
https://access.redhat.com/articles/3641742

"

   /usr/share/ovirt-engine/services/ovirt-engine/ovirt-engine.conf:

Raw

ENGINE_DB_MIN_CONNECTIONS=1
ENGINE_DB_MAX_CONNECTIONS=200

    /var/opt/rh/rh-postgresql95/lib/pgsql/data/postgresql.conf:

Raw

max_connections = 250
"

?

Comment 9 Rolfe Dlugy-Hegwer 2019-07-25 15:05:22 UTC
This document is being reviewed.


Note You need to log in before you can comment on or make changes to this bug.