Bug 1570489 - [Satellite 6] - hammer by / order option not working for sorting content-view versions
Summary: [Satellite 6] - hammer by / order option not working for sorting content-vie...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.3.1
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: Rahul Bajaj
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 04:50 UTC by jalviso
Modified: 2019-12-06 01:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3436131 0 None None None 2018-05-08 17:06:35 UTC

Description jalviso 2018-04-23 04:50:21 UTC
Description of problem:

Opening a new bugzilla for the Closed Bugzilla 1241956 as it is not fixed!


Version-Release number of selected component (if applicable): 6.3/6.3.1


How reproducible: Always


Actual results:

The issue is not fixed in Sat6.3 or 6.3.1. Please reopen this bugzilla.
Getting the result below:

[root@satellite ~]# hammer content-view version list --by NAME
---|-------------------------------|---------|-----------------------
ID | NAME                          | VERSION | LIFECYCLE ENVIRONMENTS
---|-------------------------------|---------|-----------------------
23 | ANZ Lab Core 9.0              | 9.0     | Library               
20 | ANZ Lab Core 7.0              | 7.0     |                       
19 | ANZ Lab Core 6.2              | 6.2     |                       
18 | ANZ Lab Core 6.1              | 6.1     |                       
17 | ANZ Lab Core 6.0              | 6.0     |                       
16 | ANZ Lab Core 5.0              | 5.0     |                       
15 | ANZ Lab Core 4.0              | 4.0     |                       
14 | ANZ Lab Core 3.4              | 3.4     |                       
12 | ANZ Lab Core 3.3              | 3.3     |                       
11 | ANZ Lab Core 3.2              | 3.2     |                       
8  | ANZ Lab Core 3.1              | 3.1     |                       
7  | ANZ Lab Core 3.0              | 3.0     |                       
6  | ANZ Lab Core 2.3              | 2.3     |                       
5  | ANZ Lab Core 2.2              | 2.2     |                       
4  | ANZ Lab Core 2.1              | 2.1     |                       
47 | sandpit 2.0                   | 2.0     | Library               
45 | Ceph_OSD 2.0                  | 2.0     | Library               
3  | ANZ Lab Core 2.0              | 2.0     |                       
49 | test 1.0                      | 1.0     | Library, test         
46 | sandpit 1.0                   | 1.0     |                       
31 | Ceph_OSD 1.0                  | 1.0     |                       
2  | ANZ Lab Core 1.0              | 1.0     |                       
1  | Default Organization View 1.0 | 1.0     | Library               
---|-------------------------------|---------|-----------------------
[root@satellite ~]# hammer --version
hammer (0.11.0.1)
 * hammer_cli_csv (unknown version)
 * hammer_cli_foreman (0.11.0.5)
 * hammer_cli_foreman_admin (0.0.8)
 * hammer_cli_foreman_bootdisk (0.1.3.3)
 * hammer_cli_foreman_discovery (1.0.0)
 * hammer_cli_foreman_docker (unknown version)
 * hammer_cli_foreman_openscap (unknown version)
 * hammer_cli_foreman_remote_execution (unknown version)
 * hammer_cli_foreman_tasks (unknown version)
 * hammer_cli_foreman_virt_who_configure (unknown version)
 * hammer_cli_katello (0.11.3.5)

Expected results:

Bugzilla 1241956 to be fixed but as per above output it is not fixed but original bugzilla is closed.


Additional info:

Comment 2 Gauravi 2018-05-08 10:44:18 UTC
Hello,

I would like to share some more details on the same issue with three scenarios performed on Satellite 6.3 as below:

    A) Listing specific content view using option "--content-view=":

        # hammer content-view version list --content-view=installation-kickstart --organization-id=1
        ---|----------------------------|---------|-----------------------
        ID | NAME                       | VERSION | LIFECYCLE ENVIRONMENTS
        ---|----------------------------|---------|-----------------------
        3  | installation-kickstart 2.0 | 2.0     | Library               
        2  | installation-kickstart 1.0 | 1.0     |                       
        ---|----------------------------|---------|-----------------------

        # hammer content-view version list --content-view=installation-kickstart --organization-id=1 --order=version
        ---|------|---------|-----------------------
        ID | NAME | VERSION | LIFECYCLE ENVIRONMENTS
        ---|------|---------|-----------------------

   While using "--order=version" it does not list the output at all.


    B) Listing all content views:

        # hammer content-view version list --organization-id=1
        ---|-------------------------------|---------|-----------------------
        ID | NAME                          | VERSION | LIFECYCLE ENVIRONMENTS
        ---|-------------------------------|---------|-----------------------
        3  | installation-kickstart 2.0    | 2.0     | Library               
        6  | ccv 1.0                       | 1.0     | Library               
        5  | reproduce 1.0                 | 1.0     | Library               
        4  | Test 1.0                      | 1.0     | Library, Production   
        2  | installation-kickstart 1.0    | 1.0     |                       
        1  | Default Organization View 1.0 | 1.0     | Library               
        ---|-------------------------------|---------|-----------------------

        # hammer content-view version list --organization-id=1 --order=version
        ---|------|---------|-----------------------
        ID | NAME | VERSION | LIFECYCLE ENVIRONMENTS
        ---|------|---------|-----------------------

   While using "--order=version" it does not list the output at all.


    C) --order 'name DESC' or 'name ASC'(sorting based on name):

        # hammer content-view version list --organization-id=1 --order 'name DESC'
        ---|------|---------|-----------------------
        ID | NAME | VERSION | LIFECYCLE ENVIRONMENTS
        ---|------|---------|-----------------------

   While using "--order=version" it does not list the output at all.


--order parameter does not work in either of the above three scenarios whereas scenario A) and B) works as expected in Satellite 6.2.14

Comment 6 Bryan Kearney 2019-11-04 14:33:51 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 8 Bryan Kearney 2019-12-03 12:53:16 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.