Bug 1570517 - [3.9.z] Install failed when firewalld used
Summary: [3.9.z] Install failed when firewalld used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.9.z
Assignee: Jeremiah Stuever
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 06:54 UTC by Weihua Meng
Modified: 2018-12-13 19:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 19:26:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1568689 0 high CLOSED Install failed when firewalld used 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2018:3748 0 None None None 2018-12-13 19:27:10 UTC

Internal Links: 1568689

Description Weihua Meng 2018-04-23 06:54:10 UTC
Description of problem:
[3.9.z] Install failed when firewalld used
the released v3.9.14 does not have such issue.

Version-Release number of the following components:
openshift-ansible-3.9.24-1.git.0.d0289ea.el7

How reproducible:
Always

Steps to Reproduce:
1. Install OCP 3.9 with firewalld enabled
os_firewall_use_firewalld=true

Actual results:
Job failed
TASK [openshift_node : Add firewalld allow rules] ******************************
Monday 23 April 2018  00:44:11 -0400 (0:00:00.055)       0:09:05.986 ********** 
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: AttributeError: 'AnsibleModule' object has no attribute 'fail'
failed: [wmengrpm39fw-master-etcd-1.0423-2kn.qe.rhcloud.com] (item={u'port': u'10250/tcp', u'service': u'Kubernetes kubelet'}) => {"changed": false, "failed": true, "item": {"port": "10250/tcp", "service": "Kubernetes kubelet"}, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_A0odsd/ansible_module_firewalld.py\", line 936, in <module>\n    main()\n  File \"/tmp/ansible_A0odsd/ansible_module_firewalld.py\", line 788, in main\n    module.fail(msg='firewall is not currently running, unable to perform immediate actions without a running firewall daemon')\nAttributeError: 'AnsibleModule' object has no attribute 'fail'\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 1}

Expected results:
Install succeeds

Comment 2 Jeremiah Stuever 2018-11-14 18:27:10 UTC
PR https://github.com/openshift/openshift-ansible/pull/8160

Available in openshift-ansible-3.9.27-1

Comment 3 Weihua Meng 2018-11-19 03:05:33 UTC
Fixed.

openshift-ansible-3.9.53-1.git.0.c8db613.el7.noarch

Kernel Version: 3.10.0-957.el7.x86_64
Operating System: Red Hat Enterprise Linux Server 7.6 (Maipo)

Comment 6 errata-xmlrpc 2018-12-13 19:26:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3748


Note You need to log in before you can comment on or make changes to this bug.