Bug 1570550 - Provisioning using VMWare template fails with error "configSpec.bootOptions.bootOrder"
Summary: Provisioning using VMWare template fails with error "configSpec.bootOptions.b...
Keywords:
Status: CLOSED DUPLICATE of bug 1398317
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.3.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 08:20 UTC by Amaani S Karimi
Modified: 2019-08-12 14:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 15:00:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3421061 0 None None None 2018-04-23 08:28:02 UTC

Description Amaani S Karimi 2018-04-23 08:20:12 UTC
Description of problem:
provision a VM with image cloning with our satellite 6 in VMware and got the error "Failed to create a compute OpenShift Cluster NBC (VMware) instance <FQDN>: InvalidArgument: A specified parameter was not correct configSpec.bootOptions.bootOrder".

Version-Release number of selected component (if applicable):

Red Hat Satellite 6.3.1

How reproducible:

100% reproducible


Actual results:

 got the error "Failed to create a compute OpenShift Cluster NBC (VMware) instance <FQDN>: InvalidArgument: A specified parameter was not correct

Expected results:

Provisioning should work fine

Additional info:

maybe it is because of older "fog-vsphere" version, not sure.
this can help:-  http://projects.theforeman.org/issues/14160 
                  https://github.com/fog/fog-vsphere/pull/98

Comment 5 Brad Buckingham 2018-05-01 15:00:39 UTC

*** This bug has been marked as a duplicate of bug 1398317 ***


Note You need to log in before you can comment on or make changes to this bug.