Bug 1570552 - Email composing loses Text when clearing selection by clicking
Summary: Email composing loses Text when clearing selection by clicking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-23 08:20 UTC by Jonathan Haas
Modified: 2018-04-24 14:48 UTC (History)
13 users (show)

Fixed In Version: gtk3-3.22.30-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 11:24:16 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME gtk issues 132 None None None 2018-04-23 16:09:00 UTC

Description Jonathan Haas 2018-04-23 08:20:22 UTC
Description of problem:

When writing emails, you often lose text you enter. This happens both in Evolution and Geary, so I suspect some webkit bug. Please move to the correct component if appropriate.


Version-Release number of selected component (if applicable):

evolution-3.28.1-2.fc28.x86_64
geary-0.12.1-1.fc28.x86_64
webkit2gtk3-2.20.1-1.fc28

How reproducible:

Always.

Steps to Reproduce:
1. Compose a new Mail in Evolution
2. Enter "Test" in the body
3. Select "Test" with double click
4. (optionally) make the text italic or something
5. Click on the right beside the now selected "Test"

Actual results:

The body is empty again.


Expected results:

The body still contains "Test"

Additional info:

Comment 1 Fedora Blocker Bugs Application 2018-04-23 08:23:48 UTC
Proposed as a Blocker and Freeze Exception for 28-final by Fedora user jonha using the blocker tracking app because:

 Sending an email is basic functionality of Evolution and that isn't working correctly. Also causes possible data loss (you can get your data back with Ctrl+Z however).

Comment 2 Jonathan Haas 2018-04-23 08:35:54 UTC
This also happens with content textfields in Epiphany/Web.

Comment 3 Jonathan Haas 2018-04-23 09:03:12 UTC
Seems to happen only under Wayland.

Comment 4 Lukas Ruzicka 2018-04-23 11:50:53 UTC
Hello, I have reproduced this behaviour. I have tested the following cases:

1) Installation of Fedora Live Workstation (build 2018-04-22). The problems appears as described. 
2) Latest update of Fedora Workstation, Gnome running on Xorg. The problem could not be reproduced. Everything worked normally.
3) Lates update of Fedora Workstation, Evolution in Fluxbox. Problem was not reproduced, everything seemed to work normally.

+1 to the blocker, since it violates the release criteria for Final release:

===
All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. 
===

Comment 5 Stephen Gallagher 2018-04-23 13:19:16 UTC
I'm -1 to considering this a blocker. It's a *bad* bug, but I wouldn't argue that it's blocker-level. Emails can still be written, there is a simple workaround of ctrl-Z and this can be fixed in a post-release update.

I think this should be added to Common Bugs and I'd certainly offer it a +1 FE given the severity, but I am pretty sure that if this was the last blocker at a Go/No-Go meeting, we wouldn't slip for it.

Comment 6 Michael Catanzaro 2018-04-23 16:12:04 UTC
This should be fixed in GTK+ 3.22.30

Comment 7 Fedora Update System 2018-04-23 16:15:48 UTC
gtk3-3.22.30-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dede7ba6ae

Comment 8 František Zatloukal 2018-04-23 17:05:59 UTC
Discussed during the 2018-04-23 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test" (on the basis that being able to type, select and unselect text is pretty 'basic functionality' for Evolution, dissenting votes from sgallagh and lailah)

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-04-23/f28-blocker-review.2018-04-23-16.00.log.txt

Comment 9 Adam Williamson 2018-04-23 19:26:00 UTC
So, I was worried by the fact that the upstream bug linked here seems really rather different in description from this bug. The upstream bug is approximately about auto-scroll happening unexpectedly, whereas this bug is about highlighted text unexpectedly disappearing, which seems much worse.

For the record, this seems to be addressed here:

https://bugs.webkit.org/show_bug.cgi?id=184446#c9

That's a report that sounds exactly like this bug, and in that comment, Carlos both identifies the commit that seems to have caused the problem - "modules: Add wayland IM implementation" - and states that the same commit which fixed the auto-scroll bug, "wayland: Don't emit signals if nothing changed", also fixes this bug.

Given that it *does* seem reasonable to mark the GTK+ 3.22.30-1 update (which includes that fix) as fixing this, but it'd be great if J. Haas and Lukas can confirm they can no longer reproduce the problem with 3.22.30-1.

I'm a *little* concerned about taking an entire GTK+ version bump as the fix for this blocker bug, but at least the update has been around nearly a week and has good karma. I'm going to build a test ISO and run it through openQA before requesting a stable push, though, just to be safe.

Comment 10 Jonathan Haas 2018-04-24 07:32:08 UTC
(In reply to Adam Williamson from comment #9)
> Given that it *does* seem reasonable to mark the GTK+ 3.22.30-1 update
> (which includes that fix) as fixing this, but it'd be great if J. Haas and
> Lukas can confirm they can no longer reproduce the problem with 3.22.30-1.

I can no longer reproduce the problem with the testing version.

Comment 11 Fedora Update System 2018-04-24 11:24:16 UTC
gtk3-3.22.30-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 sumantro 2018-04-24 12:07:08 UTC
gtk3-3.22.30-1.fc28 fixes this bug. I just confirmed it.

Comment 13 Adam Williamson 2018-04-24 14:48:41 UTC
Great, thanks for all the feedback, folks!


Note You need to log in before you can comment on or make changes to this bug.