Bug 1570566 - installation of web console fails behind proxy
Summary: installation of web console fails behind proxy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.z
Assignee: Vadim Rutkovsky
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 09:08 UTC by Kenjiro Nakayama
Modified: 2018-07-19 07:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-18 16:10:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3424511 0 None None None 2018-04-26 08:30:20 UTC

Description Kenjiro Nakayama 2018-04-23 09:08:07 UTC
Description of problem:

- When running installation, "Verify that the web console is running" task fails with "Curl(56) Received HTTP code 502 from proxy after CONNECT".

Version-Release number of selected component (if applicable):

- OCP 3.9

How reproducible: 100% (behind proxy)

Steps to Reproduce:
1. Running deploy_cluster.yml behind proxy.

  # ansible-playbook /usr/share/ansible/openshift-ansible/playbooks/deploy_cluster.yml


Actual results:

- "Verify that the web console is running" task fails with "Curl(56) Received HTTP code 502 from proxy after CONNECT". (This curl error message would depend on the environment though.)


Expected results:

- Playbook completes successfully.


Additional info:

- "curl -k --noproxy "*" https://webconsole.openshift-web-console.svc/healthz" worked fine, so noproxy is not working with ansible playbook.
- proposal patch: https://github.com/openshift/openshift-ansible/pull/7338

Comment 1 Vadim Rutkovsky 2018-04-24 13:29:23 UTC
Cherrypicked on 3.9 - https://github.com/openshift/openshift-ansible/pull/8106

Comment 2 Vadim Rutkovsky 2018-04-27 08:31:14 UTC
Fix is available in openshift-ansible-3.9.27-1

Comment 3 Gan Huang 2018-04-28 07:33:14 UTC
1. Adding global proxy environments to the hosts to be installed:

# tail /etc/profile
export http_proxy=http://xx.redhat.com:3128
export https_proxy=http://xx.redhat.com:3128

2.Try to reproduce the issue, but failed unfortunately by using openshift-ansible-3.9.24-1.git.0.d0289ea.el7.noarch.rpm. Installation could be completed successfully

3. Make sure the test scenario is same with customers'

# curl -k --noproxy "*" https://webconsole.openshift-web-console.svc/healthz
ok
# curl -k https://webconsole.openshift-web-console.svc/healthz
curl: (56) Received HTTP code 404 from proxy after CONNECT

4. Again, try the installation with openshift-ansible that the patch applied. Installation succeed with openshift-ansible-3.9.27-1.git.0.52e35b5.el7.noarch.rpm

From the testing above, unable to reproduce the issue. Please correct me if any steps are incorrect. Moving to verify at this point.


Note You need to log in before you can comment on or make changes to this bug.