Bug 157061 - dovecot does not understand mmdf format mail boxes
dovecot does not understand mmdf format mail boxes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-06 11:40 EDT by Alain D D Williams
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 12:46:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain D D Williams 2005-05-06 11:40:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050426 Red Hat/1.7.7-1.4.2.centos4

Description of problem:
On upgrading from readhat 9 to RH E4 I find that I can no longer use the IMAP (& POP) daemon provided to access my mail boxes. I keep mail boxes in mmdf format since it is superior to plain mbox format.

This is more of a problem in the choice of dovecot as an IMAP daemon. It means that an upgrade has been more difficult than it should have been.

I have mailed the dovecot maintainer, but not heard anything back.

In the mean time I have installed wu-imap.

Other than that -- thanks for a good product.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect using pop3 or imap and try to read mail - dovecot fails since it does not recognise the mail box format.

Additional info:
Comment 1 John Dennis 2005-05-06 12:46:30 EDT
Did you look at the contents of this directory?

/usr/share/doc/dovecot-*/UW-to-Dovecot-Migration

It does not specifically handle mmdf format, but mmdf is so close to mbox it
shouldn't be hard.

One could argue that maildir is superior to both mbox and mmdf, dovecot supports
maildir and the above can help you migrate.

The truth is, mmdf is not common enough for us to go out of our way to support
mmdf. The MTA's we ship either use mbox, maildir, or lmtp. As a consequence I'm
sorry to say I don't think mmdf support is something we would put engineering
work into. If subsequent releases of dovecot support mmdf that support will of
course be included in our distribution, however as you probably inferred from
the lack of response from Timo I don't think mmdf is high on the feature list
for dovecot. I suspect for pretty much the same reasons, flat files are not
efficient and mmdf usage currently is minimal.
Comment 2 Alain D D Williams 2005-05-09 06:53:34 EDT
I have now heard from Timo, he says that he has plans to implement MMDF after he
has hit v1.0. I shall stick with UW-imap 'till then.

I can't find a file like UW-to-Dovecot-Migration on my machine or in the source
RPM, but that is not important.

I was not suggesting that RedHat make the changes themselves, my purpose in
reporting it was that it is something that you should know about & perhaps put
on a FAQ or something.

mmdf format is superior to mbox format, but I don't propose to start a war on
the topic.

Thanks for your reply & a great product.

Note You need to log in before you can comment on or make changes to this bug.