Bug 157072 - postscript file crashes X server
Summary: postscript file crashes X server
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
: 157079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-06 16:33 UTC by jmccann
Modified: 2015-01-14 23:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 16:12:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broken.ps.gz (10.67 KB, application/octet-stream)
2005-05-06 16:33 UTC, jmccann
no flags Details

Description jmccann 2005-05-06 16:33:49 UTC
Description of problem:
Attached postscript file crashes X server.

Comment 1 jmccann 2005-05-06 16:33:49 UTC
Created attachment 114087 [details]
broken.ps.gz

Comment 2 Ray Strode [halfline] 2005-05-06 16:47:45 UTC
Hi William,

Can you provide more details to what you mean by "crash"?  Does it bring you
back to the GDM login screen? Or does it freeze up hard?  If it freezes up can
you still move your mouse?

Also, what versions of xorg-x11 and ggv do you have installed?

Thanks.

Comment 3 jmccann 2005-05-06 16:53:50 UTC
On RHEL4 it freezes up hard and I can't move the mouse.  On FC3 it brings me
back to GDM.

RHEL4: xorg-x11-6.8.1-23.EL
FC3: xorg-x11-6.8.2-1.FC3.13

FYI, I also reported this to evince upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=303264

I'm setting up a workstation where I can test this a bit more.

Comment 4 jmccann 2005-05-06 17:07:16 UTC
*** Bug 157079 has been marked as a duplicate of this bug. ***

Comment 5 Ray Strode [halfline] 2005-05-06 17:11:40 UTC
I'm going to assign this bug to the xorg team.  X shouldn't be crashing when an
app does something abnormal.  Also, some of the xorg team have done extensive
development work on evince and so are more qualified than me to look at this
problem.

Comment 6 jmccann 2005-05-06 21:11:38 UTC
Actually, on RHEL4 it only appears to freeze up hard sometimes.  The video state
gets corrupted somehow even when switching VTs.  Sometimes X dies and GDM
restarts  and things seems normal.

Comment 7 Mike A. Harris 2006-06-27 16:20:31 UTC
If this issue is still occuring in the latest Red Hat Enterprise Linux 4
updates, please contact Red Hat Support Services and file an official
support ticket by visiting http://www.redhat.com/support or by calling
1-888-RED-HAT1 depending on the type of support contract.



Comment 8 Matěj Cepl 2007-06-20 16:12:03 UTC
Reporter, can you still reproduce this bug with updated RHEL4? The Xorg
shouldn't crash now. However, note that Xorg is asked to create for ggv REALLY
huge bitmap (around 1.5GB according to upstream bug) so if you have less memory
you can your computer into state which looks like frozen (and for all your
purposes it is -- you cannot even move a mouse), but unfortunately it is just a
characteristic of the current single-threaded X server which waits until this
request is completed.

There used to be a bug in X server which crashed when asking for allocation of
extremely large pixmaps, but that should be fixed (everywhere including RHEL4).

Regretting it but I have to close this as CANTFIX (because it was already
fixed). Reopen with additional information if you have any.


Note You need to log in before you can comment on or make changes to this bug.