Bug 157077 - editing selected resource properties from the 'Service Management' doesn't work
editing selected resource properties from the 'Service Management' doesn't work
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-06 12:52 EDT by Corey Marthaler
Modified: 2009-04-16 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 17:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-05-06 12:52:35 EDT
Description of problem:
If you highlight a resource (in the service mgmt window), and then click edit,
and then change params and hit OK, nothing happens, the changes are not
reflected. Not only that but the maximized (highlighted) resource gets minimized
right after the edit attempt so you have to re-maximize inorder to see this.

Version-Release number of selected component (if applicable):
-48

How reproducible:
everytime
Comment 1 Corey Marthaler 2005-05-06 13:06:23 EDT
Actually, now it appears that whats happening is rather than the resource being
edited, a new one is just being created.
Comment 2 Jim Parsons 2005-05-09 17:34:10 EDT
Fixed in 0.9.51-1.0
Comment 3 Corey Marthaler 2005-05-10 15:38:36 EDT
Now the 'Edit Selected Resource Properties' doesn't even highlight when the
resource is selected.
Comment 4 Jim Parsons 2005-05-11 11:53:34 EDT
I think you must have selected a shared resource. When shared resources are
selected within the service mgmy window, the edit props button is not made
active because editing a shared service would affect other consumers of this
resource. Editing of shared resources can only happen throught the 'edit
resource' path, where the necessary warnings are in place.

A resource that is configured as local to a service can be edited within the
service mgmt window.

Could this be what happened? Otherwise, I am unable to reproduce the phenom this
ticket describes.
Comment 5 Corey Marthaler 2005-05-11 12:35:10 EDT
That is the case. 

Maybe the 'edit prop' button should be changed to 'Edit Selected Private Resouce
Properties' so that it's more intuitive for the user. You already differentiate
between Add/create a private/shared and Attach a private/shared. If not then
feel free to close.
Comment 6 Corey Marthaler 2005-05-19 15:31:36 EDT
Also, when you are editing a private resource, it doesn't actually get edited,
it just creates a new one similar to bz 156718.
Comment 7 Jim Parsons 2005-05-24 09:53:28 EDT
I have changed the label for the button in question, and the issue in comment #5
above has been fixed in 0.9.57-1.0
Comment 8 Corey Marthaler 2005-05-24 17:43:25 EDT
The label is changed, however the issue in comment #6 still exists. An edit,
just creates a new resource as opposed to editing the original one.
Comment 9 Jim Parsons 2005-05-25 12:49:47 EDT
Finally Got It! State var was not being set.

Available in 0.9.62-1.0
Comment 10 Corey Marthaler 2005-05-26 17:35:00 EDT
fix verified.

Note You need to log in before you can comment on or make changes to this bug.