Bug 1570786 - unclear error when assign FIP to VM when there is no external gateway
Summary: unclear error when assign FIP to VM when there is no external gateway
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstacksdk
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Bernard Cafarelli
QA Contact: nlevinki
URL:
Whiteboard:
: 1582180 1619384 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 12:15 UTC by Eran Kuris
Modified: 2020-03-10 11:53 UTC (History)
12 users (show)

Fixed In Version: python-openstacksdk-0.11.4-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 11:52:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1760405 0 None None None 2018-05-21 14:02:58 UTC
OpenStack Storyboard 1757063 0 None None None 2018-05-30 14:59:44 UTC
OpenStack Storyboard 1760405 0 None None None 2018-05-30 14:59:22 UTC
OpenStack Storyboard 2001973 0 None None None 2018-05-30 15:00:03 UTC
OpenStack gerrit 555142 0 'None' MERGED Add 409 ConflictException 2020-10-28 08:32:45 UTC
OpenStack gerrit 571101 0 'None' MERGED Modify the error message when unsetting gateway and setting FIP 2020-10-28 08:32:45 UTC
OpenStack gerrit 633739 0 'None' MERGED Modify the error message when unsetting gateway and setting FIP 2020-10-28 08:33:01 UTC
OpenStack gerrit 651274 0 'None' ABANDONED Add 409 ConflictException 2020-10-28 08:32:46 UTC
OpenStack gerrit 689608 0 'None' MERGED Openstacksdk Queens 0.11.4 2020-10-28 08:32:45 UTC
Red Hat Product Errata RHBA-2020:0769 0 None None None 2020-03-10 11:53:28 UTC

Description Eran Kuris 2018-04-23 12:15:03 UTC
Description of problem:
when assigning FIP to VM when there is no external gateway we get unclear error message:
  openstack floating ip set --port 64488a67-b79c-4bfa-a542-e7c607e762e3 9a868c30-1c7b-484c-9784-cb7ef9db556f
NotFoundException: Unknown error

Version-Release number of selected component (if applicable):

13 2018-04-19.2
(overcloud) [stack@undercloud-0 ~]$ rpm -qa |grep openstackclient
python-openstackclient-lang-3.14.1-1.el7ost.noarch
python2-openstackclient-3.14.1-1.el7ost.noarch


How reproducible:
100%

Comment 1 Brian Haley 2018-05-21 14:02:58 UTC
There is an upstream bug tracking this, linked.  I'll ping the owner again and re-assign if he's not making progress.

Comment 4 Brian Haley 2018-05-30 14:58:46 UTC
*** Bug 1582180 has been marked as a duplicate of this bug. ***

Comment 5 Brian Haley 2018-06-01 20:03:39 UTC
The two patches for python-openstacksdk have merged that fix this issue.  I am assuming they would need to be cherry-picked downstream, will have to find out if this component is different.

Comment 6 Julie Pichon 2018-08-21 14:46:05 UTC
*** Bug 1619384 has been marked as a duplicate of this bug. ***

Comment 8 Brian Haley 2019-02-25 20:39:14 UTC
Changed should all be in stable/queens now, so will flow downstream in the next rebase.

Comment 11 Steve Linabery 2019-03-11 14:47:17 UTC
(In reply to Brian Haley from comment #8)
> Changed should all be in stable/queens now, so will flow downstream in the
> next rebase.

https://review.openstack.org/#/c/555142/ is only on upstream master. Does it need to be backported to stable/queens to fix this bug?

Comment 12 Brian Haley 2019-04-09 15:27:29 UTC
Picked to upstream stable/queens.

Comment 13 Brian Haley 2019-04-12 21:13:06 UTC
This is in the downstream version of the openstacksdk library:

python-openstacksdk/0.13.0/0.20180511080316.7c723f6.el7ost

Comment 18 Jon Schlueter 2019-10-15 13:44:26 UTC
python-openstacksdk is currently pinned in RDO Queens Trunk pipeline to 0.11.3 tag 

https://github.com/redhat-openstack/rdoinfo/blob/master/tags/queens.yml#L452

so a tag upstream from the stable/queens branch or a bump to rdoinfo would be needed to start testing with this patch in RDO Queens Trunk CI.

Comment 19 Brian Haley 2019-10-15 13:53:19 UTC
Proposed https://review.opendev.org/#/c/688713/ to openstack-releases for openstack queens 0.11.4

Comment 20 Brian Haley 2019-10-22 20:17:03 UTC
There was an issue when tagging openstacksdk from PS19, but another was proposed and just merged.

https://review.opendev.org/#/c/689608/

So there should be a 0.11.4 tag in stable/queens we can import.

Comment 21 Brian Haley 2019-12-17 17:59:00 UTC
I realize my original patch was reverted, but there was a new one merged for openstacksdk queens 0.11.4, https://review.opendev.org/#/c/689608/

Hopefully that's all we need?

Comment 27 errata-xmlrpc 2020-03-10 11:52:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0769


Note You need to log in before you can comment on or make changes to this bug.