Bug 1570828 - API endpoint /archive?path=/ locks down all other calls
Summary: API endpoint /archive?path=/ locks down all other calls
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 13:18 UTC by Tomas Tomecek
Modified: 2019-11-27 22:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 22:20:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Tomecek 2018-04-23 13:18:44 UTC
Description of problem:
I'm using docker-python to get whole content of an image.

In [1]: d = docker.APIClient()

In [2]: c = d.create_container("registry.fedoraproject.org/fedora-minimal:26")

In [3]: a = d.get_archive(c, "/")

In [4]: d.remove_container(c, force=True)

On step 4, the execution is halted and default timeout, 60 seconds, is reached. No matter what I do, but after calling .get_archive, every subsequent API call is frozen.


Version-Release number of selected component (if applicable):
docker-1.13.1-52.git89b0e65.fc29.x86_64


Additional info:

On the other hand, `docker cp` works just fine.

I can see these errors in the log:
level=error msg="Can't add file /var/lib/docker/overlay2/b320d58466a25484eda56c97eed0eb489ef8394b813306c363e4ef5b39eb84c8/merged/etc/pki/ca-trust/extracted/openssl/ca-bundle.trust.crt to tar: io: read/write on closed pipe"
level=error msg="Can't close tar writer: io: read/write on closed pipe"
level=error msg="Handler for GET /v1.35/containers/a761c6235167427928305c5f4d28aa11ba75d97f5ff29949bb0a59ffdc9e7071/archive returned error: write unix /var/run/docker.sock->@: write: broken pipe"
level=error msg="Handler for GET /v1.35/containers/a761c6235167427928305c5f4d28aa11ba75d97f5ff29949bb0a59ffdc9e7071/archive returned error: error creating overlay mount to /var/lib/docker/overlay2/b320d58466a25484eda56c97eed0eb489ef8394b813306c363e4ef5b39eb84c8/merged: no such file or directory"

Comment 1 Tomas Tomecek 2018-05-16 15:54:38 UTC
Hm, I can't reproduce. I tried an older version of docker but it worked for me. The version I tried is docker-1.13.1-49.git4032bd5.fc29

Actually my colleague run into this today, I'll get in touch with him.

Comment 2 Jan Kurik 2018-08-14 10:05:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Ben Cotton 2019-10-31 19:27:53 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Ben Cotton 2019-11-27 22:20:48 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.