Bug 1570835 - Multiple CNS cluster deployment fails on OCP 3.7 install using openshift-ansible
Summary: Multiple CNS cluster deployment fails on OCP 3.7 install using openshift-ansible
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.z
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 13:46 UTC by jrmorgan
Modified: 2019-11-15 18:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 18:53:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jrmorgan 2018-04-23 13:46:55 UTC
Description of problem:

Attempt deployment of two CNS clusters associated with a single OCP cluster managed by a single heketi instance/pod -- based on the description of parameter glusterfs_cluster this should be supported:  "...a single heketi service is expected to manage multiple distinct clusters. NOTE: For natively-hosted clusters, all pods will be in the same OpenShift namespace " [1] Official docs [2] also indicate management of multiple clusters is supported: "Heketi allows administrators to add and remove storage capacity by managing either a single or multiple Red Hat Gluster Storage clusters." The limitation with openshift-ansible deployment is that both clusters will reside in the same namespace/project, which is acceptable.

Deployment of CNS is succcessful, but only a single cluster is configured, despite hostvars configured to deploy multiple CNS clusters out of box.

Version-Release number of the following components:

atomic-openshift-utils-3.7.42-1.git.2.9ee4e71.el7.noarch
yum info atomic-openshift-utils
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
Name        : atomic-openshift-utils
Arch        : noarch
Version     : 3.7.42
Release     : 1.git.2.9ee4e71.el7
Size        : 157 k
Repo        : installed
From repo   : rhel-7-server-ose-3.7-rpms
Summary     : Atomic OpenShift Utilities
URL         : https://github.com/openshift/openshift-ansible
License     : ASL 2.0
Description : Atomic OpenShift Utilities includes
            :  - atomic-openshift-installer
            :  - other utilities

How reproducible:
Always

Steps to Reproduce:
1. Configure inventory with 2 sets of 3 gluster nodes, with each set containing hostvars for a unique glusterfs_cluster ID (e.g. glusterfs_cluster=1, glusterfs_cluster=2) 
2. Execute openshift-ansible config.yml

Actual results:
No errors but all glusterfs nodes are associated with a single cluster -- observed via 'heketi-cli cluster list'

Expected results:

'heketi-cli cluster list' shows two unique clusters provisioned.

Additional info:
Inventory attached (private)

Comment 2 Jose A. Rivera 2018-08-08 14:14:12 UTC
Johnny, can you verify if this is still an issue in 3.10?

Comment 3 Johnny Liu 2018-08-08 15:00:36 UTC
@Prasanth, could cns-qe team verify if this is still an issue in 3.10?

Comment 7 Scott Dodson 2019-11-15 18:53:39 UTC
Closing this bug due to OpenShift versions < 3.11 exiting the full support phase. If this bug is still impacting releases >= 3.11 and your use cases, please reopen with those additional details and update the target release where you are impacted on a fully supported version of OpenShift.


Note You need to log in before you can comment on or make changes to this bug.