Bug 1570851 - Windows version of mingw-virt-viewer never displays locale language, always displays in English
Summary: Windows version of mingw-virt-viewer never displays locale language, always d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.3.1
: 4.3.0
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:23 UTC by David Jaša
Modified: 2019-05-08 12:40 UTC (History)
8 users (show)

Fixed In Version: spice-client-msi-4.3-1 mingw-virt-viewer-7.0-2
Doc Type: Bug Fix
Doc Text:
Previously, on a Windows client machine, if a non-English locale was selected, the spice client (remote-viewer) displayed some translated UI elements in English, not the locale language. The current release fixes this and presents those translated UI elements in the locale language.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:36:47 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1084 0 None None None 2019-05-08 12:36:52 UTC

Description David Jaša 2018-04-23 14:23:22 UTC
Description of problem:
Windows version of mingw-virt-viewer never displays locale language, always displays in English

Version-Release number of selected component (if applicable):
spice-client-msi-4.2-1.el7ev

How reproducible:
always

Steps to Reproduce:
1. run m-v-v in a session localized to some language for which m-v-v has translation
2.
3.

Actual results:
m-v-v uses English translation

Expected results:
m-v-v uses native language tranlation

Additional info:

Comment 1 Christophe Fergeau 2018-04-23 14:29:01 UTC
https://www.redhat.com/archives/virt-tools-list/2018-April/msg00038.html should fix this.

Comment 3 Uri Lublin 2019-02-25 14:13:52 UTC
I just tested remote-viewer (spice-client-msi-4.3-1 mingw-virt-viewer-7.0-2) running
on a Windows 7 Client with non English main locale.
Not everything has changed (e.g. menu is still in English) but many buttons are
translated to the locale language.

Comment 10 errata-xmlrpc 2019-05-08 12:36:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1084


Note You need to log in before you can comment on or make changes to this bug.