Bug 1570855 - Deployment of composable roles with pacemaker remote nodes fails
Summary: Deployment of composable roles with pacemaker remote nodes fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-pacemaker
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:26 UTC by Marian Krcmarik
Modified: 2018-06-27 13:54 UTC (History)
6 users (show)

Fixed In Version: puppet-pacemaker-0.7.2-0.20180413040147.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 563644 None None None 2018-04-23 14:29:55 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:54:15 UTC

Description Marian Krcmarik 2018-04-23 14:26:40 UTC
Description of problem:
Deployment of composable roles with pacemaker remote nodes fails on following error (or similar, depends on what pacemaker remote node is used):
 "Error: 'database-0' already exists", 
            "Error: /Stage[main]/Tripleo::Profile::Base::Pacemaker/Pacemaker::Resource::Remote[database-0]/Pcmk_resource[database-0]: Could not evaluate: resource create database-0 remote reconnect_interval=60 op monitor interval=20 returned error. This should never happen."

Version-Release number of selected component (if applicable):
puppet-pacemaker-0.7.2-0.20180413040146.44ef58f.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy overcloud with topology which consists of some pacemaker remote nodes

Actual results:
Overcloud deployment fails


            "Warning: This method is deprecated, please use match expressions with Stdlib::Compat::Ip_address instead. They are described at https://docs.puppet.com/puppet/latest/reference/lang_data_type.html#match-expressions. at [\"/etc/puppet/modules/tripleo/manifests/profile/base/database/mysql/client.pp\", 56]:[\"/var/lib/tripleo-config/puppet_step_config.pp\", 35]", 
            "   (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:28:in `deprecation')", 
            "Warning: This method is deprecated, please use the stdlib validate_legacy function,", 
            "                    with Stdlib::Compat::Bool. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 54]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Stdlib::Compat::Absolute_Path. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 55]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Stdlib::Compat::String. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 56]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Stdlib::Compat::Array. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 66]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Pattern[]. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 68]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Stdlib::Compat::Numeric. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 76]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]", 
            "                    with Stdlib::Compat::Hash. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ssh/manifests/server.pp\", 12]:[\"/var/lib/tripleo-config/puppet_step_config.pp\", 41]", 
            "Error: 'database-0' already exists", 
            "Error: /Stage[main]/Tripleo::Profile::Base::Pacemaker/Pacemaker::Resource::Remote[database-0]/Pcmk_resource[database-0]: Could not evaluate: resource create database-0 remote reconnect_interval=60 op monitor interval=20 returned error. This should never happen."
        ]
    }
    	to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/924cf60b-9302-42f9-b06c-71f747b95109_playbook.retry
    
    PLAY RECAP *********************************************************************
    localhost                  : ok=4    changed=1    unreachable=0    failed=1   
    
  deploy_stderr: |

Comment 11 errata-xmlrpc 2018-06-27 13:52:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.