Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1570860 - Use satellite-installer for 6.1 -> 6.2 upgrade using foreman-maintain
Summary: Use satellite-installer for 6.1 -> 6.2 upgrade using foreman-maintain
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks: 1496794
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:38 UTC by Nikhil Kathole
Modified: 2019-06-03 12:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
log in foreman-maintain.log file (538.32 KB, text/plain)
2018-04-23 14:38 UTC, Nikhil Kathole
no flags Details

Description Nikhil Kathole 2018-04-23 14:38:02 UTC
Created attachment 1425676 [details]
log in foreman-maintain.log file

Description of problem: Upgrading 6.1 -> 6.2 failed at installer-upgrade while using foreman-maintain command
"foreman-maintain upgrade run --target-version 6.2 -y". 


Version-Release number of selected component (if applicable): 

 # rpm -qa | grep maintain
rubygem-foreman_maintain-0.1.5-1.el7sat.noarch

How reproducible: always


Steps to Reproduce:
1. Install fresh 6.1.12
2. foreman-maintain upgrade run --target-version 6.2 -y

Actual results: Upgrade failed at

 --------------------------------------------------------------------------------
 Procedures::Installer::Upgrade: 
 ERROR: katello-installer is no longer used.  Please use 'satellite-installer --scenario satellite'.
        For more information on available options, include '--help'.
                                                                       [FAIL]
 Failed executing LANG=en_US.utf-8 katello-installer --upgrade, exit status 1
 --------------------------------------------------------------------------------
 Scenario [Migration scripts to Satellite 6.2] failed.
 
 The following steps ended up in failing state:
 
   [installer-upgrade]
 
 Resolve the failed steps and rerun
 the command. In case the failures are false positives,
 use --whitelist="installer-upgrade"
 

production.log showed

E, [2018-04-23 09:56:50-0400 #12894] ERROR -- : Failed executing LANG=en_US.utf-8 katello-installer --upgrade, exit status 1 (ForemanMaintain::Error::ExecutionError)
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/utils/command_runner.rb:50:in `execution_error'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/concerns/system_helpers.rb:53:in `execute!'
/usr/share/gems/gems/foreman_maintain-0.1.5/definitions/procedures/installer/upgrade.rb:4:in `run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/executable.rb:120:in `__run__'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner/execution.rb:79:in `block (2 levels) in run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner/execution.rb:103:in `capture_errors'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner/execution.rb:78:in `block in run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner/execution.rb:97:in `with_metadata_calculation'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner/execution.rb:77:in `run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner.rb:109:in `run_step'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner.rb:98:in `run_steps'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner.rb:91:in `execute_scenario_steps'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/runner.rb:45:in `run_scenario'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:138:in `block in run_phase'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:183:in `with_non_empty_scenario'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:134:in `run_phase'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:82:in `block in run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:77:in `each'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/upgrade_runner.rb:77:in `run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/cli/upgrade_command.rb:80:in `execute'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
/usr/share/gems/gems/foreman_maintain-0.1.5/lib/foreman_maintain/cli.rb:21:in `run'
/usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
/usr/share/gems/gems/foreman_maintain-0.1.5/bin/foreman-maintain:12:in `<top (required)>'
/usr/bin/foreman-maintain:23:in `load'
/usr/bin/foreman-maintain:23:in `<main>'
I, [2018-04-23 09:56:50-0400 #12894]  INFO -- : foreman-maintain command finished with


Expected results: Successful upgrade.


Additional info: 

1. Rerunning the foreman-maintain upgrade run command works.
2. running upgrade "foreman-maintain upgrade run --target-version 6.2 -y" works fine.

Comment 2 Kavita 2018-04-27 08:36:32 UTC
Recently, we have added installer changes in upstream/foreman-maintain.

For a reference, pull-request URL - https://github.com/theforeman/foreman_maintain/pull/159.

With these changes, above problem will get resolved.

Comment 3 Bryan Kearney 2019-05-02 19:06:47 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2019-06-03 12:05:27 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.