Bug 1570867 - Consider replacing ACLs with selinux (or something else)
Summary: Consider replacing ACLs with selinux (or something else)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: insights-client
Version: 7.6
Hardware: All
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: jcrafts
QA Contact: Jeff Needle
URL:
Whiteboard:
: 1612630 (view as bug list)
Depends On:
Blocks: 1122832 1592996
TreeView+ depends on / blocked
 
Reported: 2018-04-23 14:57 UTC by Kyle Lape
Modified: 2020-06-10 13:16 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-10 13:16:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kyle Lape 2018-04-23 14:57:28 UTC
insights-client sets ACLs in its post install script to support running the client as a non-root user, but this causes RPM validation warnings.  We should explore alternatives (like selinux) to achieve the same goal.

Comment 2 Kyle Lape 2018-08-06 18:37:55 UTC
*** Bug 1612630 has been marked as a duplicate of this bug. ***

Comment 3 Kyle Lape 2018-10-01 15:43:18 UTC
*** Bug 1634100 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.