Bug 1570870 - example in tpm2_create manpage showing non-existing option '-o'
Summary: example in tpm2_create manpage showing non-existing option '-o'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tpm2-tools
Version: 7.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: 7.7
Assignee: Jerry Snitselaar
QA Contact: Vilém Maršík
URL:
Whiteboard:
Depends On:
Blocks: 1656539
TreeView+ depends on / blocked
 
Reported: 2018-04-23 15:09 UTC by Vilém Maršík
Modified: 2019-08-06 13:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:03:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2182 0 None None None 2019-08-06 13:03:16 UTC

Description Vilém Maršík 2018-04-23 15:09:50 UTC
Description of problem:
option '-o' from the manpage example is not recognized by tpm2_create

Version-Release number of selected component (if applicable):
tpm2-tools-3.0.1-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. man tpm2_create
2. try the examples at the end:
EXAMPLES
              tpm2_create -H 0x81010001 -P abc123 -K def456 -g sha256 -G keyedhash-I data.File -o opu.File
(^ BTW, space missing before the '-I' option)
              tpm2_create -c parent.context -P abc123 -K def456 -g sha256 -G keyedhash -I data.File -o opu.File
              tpm2_create -H 0x81010001 -P 123abc -K 456def -X -g sha256 -G keyedhash -I data.File -o opu.File


Actual results:
# tpm2_create -H 0x81010001 -g sha256 -o opu.File
tpm2_create: invalid option -- 'o'
ERROR: Unknown Argument: o

Expected results:
only existing options in manpage example

Additional info:

Comment 2 Jerry Snitselaar 2019-02-05 00:49:15 UTC
Submitted a patch upstream to clean this up since it still exists. Will apply once accepted.

Comment 5 Vilém Maršík 2019-06-21 18:07:24 UTC
Manpage now shows examples without the nonexisting "-o" option:

EXAMPLES
              tpm2_create -H 0x81010001 -P abc123 -K def456 -g sha256 -G keyedhash-I data.File
              tpm2_create -c parent.context -P abc123 -K def456 -g sha256 -G keyedhash -I data.File
              tpm2_create -H 0x81010001 -P 123abc -K 456def -X -g sha256 -G keyedhash -I data.File

tpm2-tools-3.0.4-3.el7.x86_64
RHEL-7.7-20190614.n.0 Server x86_64
Setting verified.

Comment 7 errata-xmlrpc 2019-08-06 13:03:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2182


Note You need to log in before you can comment on or make changes to this bug.