Bug 1570878 - [nfs-ganesha] Attr_Expiration_Time not a Export_Defaults option
Summary: [nfs-ganesha] Attr_Expiration_Time not a Export_Defaults option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z3
: 3.0
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks: 1567511
TreeView+ depends on / blocked
 
Reported: 2018-04-23 15:36 UTC by Ram Raja
Modified: 2018-05-15 18:21 UTC (History)
11 users (show)

Fixed In Version: RHEL: nfs-ganesha-2.5.5-5.el7cp Ubuntu: nfs-ganesha_2.5.5-8redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:20:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
ganesha config file (4.69 KB, text/plain)
2018-04-23 15:36 UTC, Ram Raja
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github nfs-ganesha nfs-ganesha issues 289 0 None closed Attr_Expiration_Time not a Export_Defaults option 2020-07-14 09:49:42 UTC
Red Hat Product Errata RHBA-2018:1563 0 None None None 2018-05-15 18:21:25 UTC

Description Ram Raja 2018-04-23 15:36:37 UTC
Created attachment 1425684 [details]
ganesha config file

Description of problem:
To disable Ganesha's attribute caching for all exports, you need to set
'Attr_Expiration_Time=0' as a EXPORT_DEFAULTS options. This is not working.
But we need this working for setting up NFS-Ganesha in OpenStack Manila deployments, where we want to turn off attribute caching.

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Setup Ganesha over CephFS and use the attached ganesha.conf file.

2. Start the ganesha server.

3. Check out the ganesha log file for warnings or errors.

Actual results: See a warning in the ganesha log file,
[main] config_errs_to_log :CONFIG :WARN :Config File (/etc/ganesha/ganesha.conf:10): Unknown parameter (Attr_Expiration_Time)

Expected results: Shouldn't see the warning in the ganesha in the config file.


Additional info:

Comment 3 Ram Raja 2018-04-23 15:37:57 UTC
The fix is in upstream nfs-ganesha project's next branch,
https://github.com/nfs-ganesha/nfs-ganesha/commit/e76c786d1f41d14b5bc3e4086136e11e93f04021

Shouldn't be hard to backport and it's easy to test.

Comment 21 Ramakrishnan Periyasamy 2018-05-04 12:26:01 UTC
Thanks Ramana, 

Moving this bug to verified state.

Comment 24 errata-xmlrpc 2018-05-15 18:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.