Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1570927 - [OSP12][ODL] opendaylight_api reports false unhealthy state
Summary: [OSP12][ODL] opendaylight_api reports false unhealthy state
Keywords:
Status: CLOSED DUPLICATE of bug 1549218
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Dan Prince
QA Contact: Omri Hochman
Andrew Burden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 18:22 UTC by Rafal Szmigiel
Modified: 2018-10-24 12:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-04-29 06:50:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rafal Szmigiel 2018-04-23 18:22:58 UTC
Description of problem:
Deployed OSP12 with ODL enabled as described in Basic installation of OpenDaylight (https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html/red_hat_opendaylight_installation_and_configuration_guide/install_opendaylight_on_the_overcloud#basic_installation_of_opendaylight)

Docker reports that container is unhealthy but it seems to be working fine. At least tests covered in the mentioned guide above don't indicate any issues.

349abb6f43a0        192.168.111.1:8787/rhosp12/openstack-opendaylight:12.0-20180405.1              "kolla_start"            2 hours ago         Up About an hour (unhealthy)                       opendaylight_api

I suspect that the problem is with /openstack/healthcheck script. It queries http://$bind_host:$bind_port/index.html but at least in my case it doesn't exist:

[root@overcloud-controller-0 opendaylight]# curl -v http://172.17.0.16:8081/index.html
* About to connect() to 172.17.0.16 port 8081 (#0)
*   Trying 172.17.0.16...
* Connected to 172.17.0.16 (172.17.0.16) port 8081 (#0)
> GET /index.html HTTP/1.1
> User-Agent: curl/7.29.0
> Host: 172.17.0.16:8081
> Accept: */*
> 
< HTTP/1.1 404 Not Found
< Cache-Control: must-revalidate,no-cache,no-store
< Content-Type: text/html;charset=ISO-8859-1
< Content-Length: 1294
< Server: Jetty(8.1.19.v20160209)
< 



Version-Release number of selected component (if applicable):
openstack-opendaylight:12.0-20180405.1

[root@overcloud-controller-0 heat-admin]# rpm -qa | grep -i -E '(openstack|docker)'
openstack-dashboard-theme-12.0.0-3.el7ost.noarch
python-django-openstack-auth-3.5.0-2.el7ost.noarch
openstack-neutron-11.0.1-8.el7ost.noarch
openstack-sahara-api-7.0.0-3.el7ost.noarch
openstack-nova-common-16.0.2-9.el7ost.noarch
openstack-ironic-api-9.1.2-3.el7ost.noarch
openstack-nova-scheduler-16.0.2-9.el7ost.noarch
openstack-swift-proxy-2.15.1-3.el7ost.noarch
openstack-gnocchi-api-4.0.3-2.el7ost.noarch
openstack-octavia-worker-1.0.1-2.el7ost.noarch
openstack-manila-5.0.1-3.el7ost.noarch
docker-1.12.6-71.git3e8e77d.el7.x86_64
openstack-swift-plugin-swift3-1.12.0-2.el7ost.noarch
openstack-octavia-common-1.0.1-2.el7ost.noarch
openstack-aodh-common-5.0.0-3.el7ost.noarch
docker-client-1.12.6-71.git3e8e77d.el7.x86_64
openstack-nova-novncproxy-16.0.2-9.el7ost.noarch
openstack-heat-api-cfn-9.0.1-3.el7ost.noarch
openstack-aodh-notifier-5.0.0-3.el7ost.noarch
openstack-ceilometer-collector-9.0.3-1.el7ost.noarch
openstack-octavia-housekeeping-1.0.1-2.el7ost.noarch
openstack-neutron-openvswitch-11.0.1-8.el7ost.noarch
openstack-zaqar-5.0.0-3.el7ost.noarch
openstack-swift-account-2.15.1-3.el7ost.noarch
openstack-selinux-0.8.11-1.el7ost.noarch
puppet-openstacklib-11.3.0-2.el7ost.noarch
docker-rhel-push-plugin-1.12.6-71.git3e8e77d.el7.x86_64
python-openstackclient-3.12.0-1.el7ost.noarch
openstack-neutron-common-11.0.1-8.el7ost.noarch
openstack-puppet-modules-11.0.0-1.el7ost.noarch
openstack-ceilometer-polling-9.0.3-1.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-4.0.3-2.el7ost.noarch
openstack-sahara-common-7.0.0-3.el7ost.noarch
openstack-mistral-api-5.2.0-1.el7ost.noarch
openstack-nova-migration-16.0.2-9.el7ost.noarch
openstack-nova-console-16.0.2-9.el7ost.noarch
openstack-glance-15.0.0-3.el7ost.noarch
openstack-heat-api-9.0.1-3.el7ost.noarch
openstack-aodh-evaluator-5.0.0-3.el7ost.noarch
openstack-sahara-7.0.0-3.el7ost.noarch
openstack-gnocchi-statsd-4.0.3-2.el7ost.noarch
openstack-ceilometer-central-9.0.3-1.el7ost.noarch
openstack-octavia-health-manager-1.0.1-2.el7ost.noarch
openstack-neutron-linuxbridge-11.0.1-8.el7ost.noarch
openstack-neutron-sriov-nic-agent-11.0.1-8.el7ost.noarch
openstack-sahara-ui-7.0.0-1.el7ost.noarch
openstack-neutron-lbaas-ui-3.0.1-2.el7ost.noarch
python-openstacksdk-0.9.17-1.el7ost.noarch
openstack-swift-container-2.15.1-3.el7ost.noarch
puppet-openstack_extras-11.3.0-2.el7ost.noarch
openstack-dashboard-12.0.0-4.el7ost.noarch
openstack-ceilometer-common-9.0.3-1.el7ost.noarch
openstack-gnocchi-common-4.0.3-2.el7ost.noarch
python-heat-agent-docker-cmd-1.4.0-1.el7ost.noarch
openstack-heat-common-9.0.1-3.el7ost.noarch
openstack-nova-compute-16.0.2-9.el7ost.noarch
openstack-mistral-event-engine-5.2.0-1.el7ost.noarch
openstack-ironic-conductor-9.1.2-3.el7ost.noarch
openstack-nova-api-16.0.2-9.el7ost.noarch
openstack-cinder-11.0.1-2.el7ost.noarch
openstack-heat-api-cloudwatch-9.0.1-3.el7ost.noarch
openstack-aodh-api-5.0.0-3.el7ost.noarch
openstack-keystone-12.0.0-3.el7ost.noarch
openstack-gnocchi-metricd-4.0.3-2.el7ost.noarch
python-openstackclient-lang-3.12.0-1.el7ost.noarch
openstack-ceilometer-ipmi-9.0.3-1.el7ost.noarch
openstack-octavia-api-1.0.1-2.el7ost.noarch
openstack-ironic-inspector-6.0.0-3.el7ost.noarch
openstack-manila-ui-2.10.2-3.el7ost.noarch
openstack-swift-object-2.15.1-3.el7ost.noarch
openstack-panko-common-3.0.0-4.el7ost.noarch
docker-common-1.12.6-71.git3e8e77d.el7.x86_64
openstack-ironic-common-9.1.2-3.el7ost.noarch
openstack-mistral-executor-5.2.0-1.el7ost.noarch
openstack-nova-conductor-16.0.2-9.el7ost.noarch
openstack-heat-engine-9.0.1-3.el7ost.noarch
openstack-aodh-listener-5.0.0-3.el7ost.noarch
openstack-ceilometer-compute-9.0.3-1.el7ost.noarch
openstack-neutron-lbaas-11.0.1-8.el7ost.noarch
python-docker-pycreds-1.10.6-3.el7.noarch
python-docker-py-1.10.6-3.el7.noarch
openstack-neutron-ml2-11.0.1-8.el7ost.noarch
openstack-ceilometer-notification-9.0.3-1.el7ost.noarch
openstack-sahara-engine-7.0.0-3.el7ost.noarch
openstack-mistral-common-5.2.0-1.el7ost.noarch
openstack-mistral-engine-5.2.0-1.el7ost.noarch
openstack-nova-placement-api-16.0.2-9.el7ost.noarch
openstack-ec2-api-5.0.0-2.el7ost.noarch
openstack-panko-api-3.0.0-4.el7ost.noarch
openstack-ceilometer-api-9.0.3-1.el7ost.noarch
openstack-neutron-metering-agent-11.0.1-8.el7ost.noarch
openstack-manila-share-5.0.1-3.el7ost.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy OSP12 with ODL enabled
2. Observe confusing unhealthy state
3. Observe that everything else works fine.

Actual results:
Health check for opendaylight_api reports false unhealthy state.

Expected results:
Correct health state is being reported.


Additional info:

Comment 1 Mike Kolesnik 2018-04-29 06:50:40 UTC

*** This bug has been marked as a duplicate of bug 1549218 ***


Note You need to log in before you can comment on or make changes to this bug.