Bug 1570932 - For OCP v3.10, the openshift-scripts RPM can only install file resources under /etc/origin/master
Summary: For OCP v3.10, the openshift-scripts RPM can only install file resources unde...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Stefanie Forrester
QA Contact: yasun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-23 18:41 UTC by Justin Pierce
Modified: 2018-07-30 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 15:37:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Pierce 2018-04-23 18:41:33 UTC
Description of problem:
For v3.10, since the master processes are being containerized, master-config.yml referencing files outside of /etc/origin/master will cause master processes to fail.

Resources like the following need to be under /etc/origin/master:

- providerSelection: /etc/openshift-free/ui-extensions/custom-templates/provider-selection-int.html
- error:/etc/openshift-free/ui-extensions/custom-templates/oauth-error-int.html

I believe the oso-deployer may need to reflect these new file locations as well. 

Version-Release number of selected component (if applicable):
v3.10.X

How reproducible:
100% / By design in v3.10

Comment 1 Stefanie Forrester 2018-04-23 23:11:26 UTC
The console extensions (UI customizations) have already been moved to https://github.com/openshift/online-console-extensions. So those won't be needed in master-config anymore. I went ahead and removed them from config management today.

The next step will be moving the oauth customizations, which need to remain in master-config. I'll just have to move the file location to /etc/origin/master in oso_deployer.

Comment 4 Stefanie Forrester 2018-06-06 13:51:10 UTC
Fixed path across all of Online. (Dedicated will get this change after the 3.9 upgrade).

Comment 5 yasun 2018-07-16 02:25:06 UTC
verified on all of Online


Note You need to log in before you can comment on or make changes to this bug.