Bug 1570962 - print the path of the corrupted object in scrub status
Summary: print the path of the corrupted object in scrub status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra Bhat
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1580540
TreeView+ depends on / blocked
 
Reported: 2018-04-23 21:00 UTC by Raghavendra Bhat
Modified: 2018-10-23 15:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1580540 (view as bug list)
Environment:
Last Closed: 2018-06-20 18:05:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Bhat 2018-04-23 21:00:29 UTC
Description of problem:

As of now, "gluster volume bitrot <volume name> scrub status" command only prints the gfid of the corrupted objects (files as of now).

The actual path of those objects is not printed. It would be better to print the paths of as much corrupted objects as possible. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-04-23 21:02:28 UTC
REVIEW: https://review.gluster.org/19928 (features/bitrot: print the path of the corrupted objects) posted (#1) for review on master by Raghavendra Bhat

Comment 2 Worker Ant 2018-05-04 11:14:27 UTC
COMMIT: https://review.gluster.org/19928 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- features/bitrot: print the path of the corrupted objects

Currently "gluster volume bitrot <volume name> scrub status"
gives the list of the corrupted objects (files as of now).
But only the gfids of those corrupted objects are seen and
one has to do getfattr, find etc operations to get the actual
path of those objects for removal etc.

This change makes an attempt to print the path of those files
as much as possible.

* Try to get the path using the on disk gfid2path xattr.

* If the above operation fails, then go for in memory path
(provided that the object has its dentry
properly created and linked in the inode table of the brick where
the corrupted object is present) So the gfid to path resolution is
a soft resolution, i.e. based on the inode and dentry cache in the
brick's memory. If the path cannot be obtained via inode table also,
then only gfid is printed.

Change-Id: Ie9a30307f43a49a2a9225821803c7d40d231de68
fixes: bz#1570962
Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Worker Ant 2018-05-04 17:20:08 UTC
REVIEW: https://review.gluster.org/19963 (make posix return errors when gfid2path key is absent) posted (#1) for review on master by Raghavendra Bhat

Comment 4 Worker Ant 2018-05-18 04:20:06 UTC
COMMIT: https://review.gluster.org/19963 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- make posix return errors when gfid2path key is absent

Change-Id: I3a8d452d00560dac5e0b7ff0b1835d1f20a59f91
updates: bz#1570962
Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 5 Shyamsundar 2018-06-20 18:05:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 6 Shyamsundar 2018-10-23 15:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.