Bug 1571034 - Miss "CURRENT/NEW TAGS" for image configuration in bc config page
Summary: Miss "CURRENT/NEW TAGS" for image configuration in bc config page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 01:48 UTC by shahan
Modified: 2018-07-30 19:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing "CURRENT/NEW TAGS" for image configuration in the TAG selectbox, in BC config page, caused by missing scope in the selectbox code. Consequence: The tags in the TAG selectbox are not grouped into "CURRENT" and "NEW TAGS" Fix: Add the scope into the selectbox grouping code Result: Tags are grouped into "CURRENT" and "NEW TAGS" groups
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:17 UTC

Description shahan 2018-04-24 01:48:46 UTC
Description of problem:
Miss "CURRENT/NEW TAGS" for image configuration in bc config page

Version-Release number of selected component (if applicable):
OpenShift Master: v3.10.0-0.27.0 
Kubernetes Master:v1.10.0+b81c8f8 
OpenShift Web Console: v3.10.0-0.27.0 

How reproducible:
Always

Steps to Reproduce:
1. oc process -f
https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app
/application-template-stibuild.json | oc create -f -
2.Wait for #1 build complete, access BC/ruby-sample-build edit page, click at Tag picker under image configuration, type a new tag "newtag1" and hit Enter, then Save
3.access BC edit page again, click Tag picker

Actual results:
just have two tags, have no parts of "CURRENT/NEW TAGS" 

Expected results:
Should have CURRENT TAGS and NEW TAG parts in tags list.

Additional info:

Comment 1 Samuel Padgett 2018-04-24 16:53:45 UTC
Marking this low priority since everything seems to work. We've just lost the group heading if I understand properly.

Comment 2 Yadan Pei 2018-04-26 09:10:02 UTC
yes, it works well we just lost the heading

Comment 3 openshift-github-bot 2018-04-27 12:27:37 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/fb1865606e6451c3b606fd53fde49e0a0842ad73
Bug 1571034 - Miss 'CURRENT/NEW TAGS' for image configuration in bc config page

https://github.com/openshift/origin-web-console/commit/144ef9bc4fb050cfe46b6a6479a2c1b6871dcdc0
Merge pull request #2980 from jhadvig/BZ1571034

Bug 1571034 - Miss 'CURRENT/NEW TAGS' for image configuration in bc config page

Comment 4 Jakub Hadvig 2018-04-27 12:52:24 UTC
Fixing PR: https://github.com/openshift/origin-web-console/pull/2980

Comment 6 shahan 2018-05-16 02:55:16 UTC
Checked this bug as the description, tag picker works well now.

OpenShift Master: v3.10.0-0.46.0 
Kubernetes Master: v1.10.0+b81c8f8 
OpenShift Web Console: v3.10.0-0.46.0

Comment 8 errata-xmlrpc 2018-07-30 19:13:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.