Bug 1571054 - Etcd was not run as static pod after upgrade rpm ocp
Summary: Etcd was not run as static pod after upgrade rpm ocp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 02:45 UTC by liujia
Modified: 2018-07-30 19:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:17 UTC

Description liujia 2018-04-24 02:45:45 UTC
Description of problem:
After upgrade rpm installed ocp to v3.10, found that 1)etcd was not run as static pod. 2) atomic-openshift-master was still updated to 3.10 which should be dropped.

# oc get all -n kube-system
NAME                                                 READY     STATUS    RESTARTS   AGE
pod/master-api-qe-jliu-rpm39-master-etcd-1           1/1       Running   1          1h
pod/master-controllers-qe-jliu-rpm39-master-etcd-1   1/1       Running   1          1h

systemctl status etcd.service
● etcd.service - Etcd Server
Loaded: loaded (/usr/lib/systemd/system/etcd.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2018-04-23 00:30:52 EDT; 3h 24min ago
Main PID: 15320 (etcd)


Version-Release number of the following components:
openshift-ansible-3.10.0-0.27.0.git.0.abed3b7.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. rpm install ocp v3.9
2. enable v3.10 ose repos and upgrade above ocp 
3.

Actual results:
Etcd was not run as static pod.

Expected results:
Master api/controllers and etcd were run as static pod after upgrade.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 liujia 2018-04-27 07:18:48 UTC
Etcd need to be run as a static pod is required for control plane in v3.10. Need this bug fixed asap.

Comment 2 Michael Gugino 2018-04-30 21:06:47 UTC
PR Submitted: https://github.com/openshift/openshift-ansible/pull/8206

Comment 3 Wei Sun 2018-05-07 03:04:46 UTC
@ QA owner:
The PR has been merged in 3.10.0-0.33.0 , please check.

Comment 4 liujia 2018-05-07 07:02:42 UTC
Blocked by bz1575507. Delete this testblocker keyword first.

Comment 7 liujia 2018-05-14 07:30:10 UTC
Verified on atomic-openshift-3.10.0-0.38.0.git.0.ae093fb.el7.x86_64

# oc get pod -n kube-system
NAME                                            READY     STATUS    RESTARTS   AGE
master-api-qe-jliu-r39a-master-etcd-1           1/1       Running   1          45m
master-controllers-qe-jliu-r39a-master-etcd-1   1/1       Running   1          45m
master-etcd-qe-jliu-r39a-master-etcd-1          1/1       Running   0          50m

# ls -la /etc/origin/node/pods/
total 16
drwx------. 2 root root   68 May 14 02:41 .
drwx------. 4 root root 4096 May 14 02:32 ..
-rw-------. 1 root root 1477 May 14 02:41 apiserver.yaml
-rw-------. 1 root root 1253 May 14 02:41 controller.yaml
-rw-------. 1 root root  922 May 14 02:34 etcd.yaml

Comment 9 errata-xmlrpc 2018-07-30 19:13:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.