Bug 1571075 - Unable to show request
Summary: Unable to show request
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.8.5
Assignee: Tina Fitzgerald
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1572700
TreeView+ depends on / blocked
 
Reported: 2018-04-24 04:55 UTC by Imaan
Modified: 2018-11-12 12:49 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 14:30:44 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Imaan 2018-04-24 04:55:06 UTC
Description of problem:
For specific catalogs whose request state is "pending", unable to show the request due to the following exception

Version-Release number of selected component (if applicable):

Red Hat CloudForms 4.5

How reproducible:

Always

Steps to Reproduce:

1. Login to CloudForms Operational Portal

2. Navigate to Services -> Requests

3. Click on the request whose state is "pending"

Actual results:

Error text:

wrong array length at 0 (expected 2, was 1) [miq_request/show]

Expected results:

It should display the request details as expected.

Comment 3 Greg McCullough 2018-04-24 13:43:24 UTC
Imaan - Is there a stack trace in the logs that could help narrow down the error.

Comment 4 Josh Carter 2018-04-24 13:50:05 UTC
[collab-shell] https://gitlab.cee.redhat.com/gss-tools/collab-shell

    # ssh your_kerb@collab-shell.usersys.redhat.com
    # cd /cases/02081731

the following files have been downloaded and extracted:
--------------------------------
	35M	evm_current_hln2327p.oocl.com_20180419_144832.tar.xz
	618M	output_file
--------------------------------

view attachments here: http://collab-shell.usersys.redhat.com/02081731/

Comment 17 Tina Fitzgerald 2018-08-23 20:24:32 UTC
Hi Imaan,

We're not able to reproduce the customer issue.  Since there have been many dialog fixes made in 5.8, we suspect the issue could already have been resolved.
Could you ask the customer to setup a test appliance and apply the 
latest 5.8 fixes to see if it resolves the reported issue?

Thanks,
Tina

Comment 18 Tina Fitzgerald 2018-08-30 18:48:43 UTC
Hi Imaan, 

Could you ask the customer for an update?

Thanks,
Tina

Comment 19 Tina Fitzgerald 2018-09-04 14:30:44 UTC
Closing ticket since the customer case has been closed.


Note You need to log in before you can comment on or make changes to this bug.