Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1571113 - Didn't use the temporary password to login to HE-VM by "hosted-engine --add-console-password"
Summary: Didn't use the temporary password to login to HE-VM by "hosted-engine --add-c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.18
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1458709
TreeView+ depends on / blocked
 
Reported: 2018-04-24 06:51 UTC by Yihui Zhao
Modified: 2018-05-10 06:29 UTC (History)
14 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.20-1.el7ev
Doc Type: Bug Fix
Doc Text:
Hosted-engine VM deployed with the ansible flow are configured for SPICE+VNC graphical consoles. hosted-engine --add-console-password should still work for the VNC console.
Clone Of:
Environment:
Last Closed: 2018-05-10 06:29:53 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
terminal_set_temporary_passwd (145.65 KB, image/png)
2018-04-24 06:51 UTC, Yihui Zhao
no flags Details
engine_side_temporary_passwd (272.49 KB, image/png)
2018-04-24 06:52 UTC, Yihui Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90721 0 master MERGED vnc: correctly set temporary password 2018-09-03 09:33:23 UTC
oVirt gerrit 90728 0 ovirt-hosted-engine-setup-2.2 MERGED vnc: correctly set temporary password 2018-04-27 16:13:12 UTC

Description Yihui Zhao 2018-04-24 06:51:22 UTC
Created attachment 1425811 [details]
terminal_set_temporary_passwd

Description of problem:
While deploying HostedEngine successfully, set a temporary password by "hosted-engine --add-console-password --password="123456", 

Use "vncviewer 10.73.73.106:5902" to login to HE-VM, but failed.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.2.2.1-0.20180420.0
cockpit-160-3.el7.x86_64
cockpit-bridge-160-3.el7.x86_64
cockpit-ws-160-3.el7.x86_64
cockpit-storaged-160-3.el7.noarch
cockpit-ovirt-dashboard-0.11.22-1.el7ev.noarch
cockpit-dashboard-160-3.el7.x86_64
cockpit-system-160-3.el7.noarch
ovirt-hosted-engine-setup-2.2.18-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch
rhvm-appliance-4.2-20180420.0.el7.noarch


How reproducible:
100%


Steps to Reproduce:
1. Clean install redhat-virtualization-host-4.2.2.1-0.20180420.0 with ks
2. Deploy HE via cockpit
3. Use "hosted-engine --add-console-password " to set a temporary password
4. Login to the HE-VM by the temporary password

Actual results:
After step4, login to HE-VM failed


Expected results:
After step4, login to HE-VM successfully


Additional info:

Comment 1 Yihui Zhao 2018-04-24 06:52:10 UTC
Created attachment 1425813 [details]
engine_side_temporary_passwd

Comment 2 Simone Tiraboschi 2018-04-24 10:25:07 UTC
Not sure if relevant but I see 10.73.73.106 in the terminal screenshot and 10.73.73.105 in the engine one.

Should the point to the same env?

Comment 3 Yihui Zhao 2018-04-24 11:03:11 UTC
(In reply to Simone Tiraboschi from comment #2)
> Not sure if relevant but I see 10.73.73.106 in the terminal screenshot and
> 10.73.73.105 in the engine one.
> 
> Should the point to the same env?

Yes , it is the same env.

Comment 4 Simone Tiraboschi 2018-04-26 17:42:56 UTC
Michal,

'hosted-engine --add-console-password' is simply calling 

    cli.VM.setTicket(
        vmID=args.vmid,
        password=args.password,
        ttl=args.ttl,
        existingConnAction='keep',
        params={},
    )

https://github.com/oVirt/ovirt-hosted-engine-setup/blob/master/src/ovirt_hosted_engine_setup/vdsm_helper.py#L87

and from the logs it run successfully but then the user cannot login with that password directly pointing a VNC client to host address on the right port.

We didn't change that code in recent months/years.

The only relevant change is that we recently switched from VNC to Spice+VNC, Could it affect our setTicket call?

Comment 5 Michal Skrivanek 2018-04-26 18:03:20 UTC
Yes. See https://github.com/oVirt/vdsm/blob/0cfab8ce3730ee89ed5b9dd9320a501d4254c0a0/lib/vdsm/virt/vm.py#L4977

You can use updateDevice instead if you need to set it on arbitrary console/protocol

Comment 6 Yihui Zhao 2018-05-03 03:14:41 UTC
Works for me with these component:

ovirt-hosted-engine-ha-2.2.11-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.20-1.el7ev.noarch
rhvm-appliance-4.2-20180427.0.el7.noarch
cockpit-dashboard-165-3.el7.x86_64
cockpit-bridge-165-3.el7.x86_64
cockpit-165-3.el7.x86_64
cockpit-storaged-165-3.el7.noarch
cockpit-ws-165-3.el7.x86_64
cockpit-ovirt-dashboard-0.11.23-1.el7ev.noarch
cockpit-system-165-3.el7.noarch
rhvh-4.2.3.0-0.20180430.0+1
ansible-2.5.2-1.el7ae.noarch


I will move to verify if the bug become to ON_QA.

Comment 8 Nikolai Sednev 2018-05-03 14:39:20 UTC
Moving to verified forth to https://bugzilla.redhat.com/show_bug.cgi?id=1571113#c6.

Comment 9 Sandro Bonazzola 2018-05-10 06:29:53 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.