Bug 1571115 - [HE] - AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycleEvent' on HE VM migration
Summary: [HE] - AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycle...
Keywords:
Status: CLOSED DUPLICATE of bug 1557754
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.2.3.2
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Doron Fediuck
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 06:52 UTC by Michael Burman
Modified: 2018-04-25 04:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 04:40:13 UTC
oVirt Team: Integration


Attachments (Terms of Use)
HE logs (3.47 MB, application/x-gzip)
2018-04-24 06:52 UTC, Michael Burman
no flags Details

Description Michael Burman 2018-04-24 06:52:03 UTC
Created attachment 1425812 [details]
HE logs

Description of problem:
[HE] - AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycleEvent' on HE VM migration.

Each time migrating the HE VM, this error appears in vdsm log - 

2018-04-24 09:42:23,331+0300 ERROR (libvirt/events) [vds] Error running VM callback (clientIF:683)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/clientIF.py", line 646, in dispatchLibvirtEvents
    v.onLibvirtLifecycleEvent(event, detail, None)
AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycleEvent'


Version-Release number of selected component (if applicable):
4.2.3.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. HE setup - Migrate the HE VM

Actual results:
AttributeError: 'NoneType' object has no attribute 'onLibvirtLifecycleEvent' in vdsm logs

Comment 1 Michael Burman 2018-04-24 06:53:03 UTC
vdsm-4.20.26-1.el7ev.x86_64
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.18-1.el7ev.noarch

Comment 2 Michal Skrivanek 2018-04-25 04:40:13 UTC

*** This bug has been marked as a duplicate of bug 1557754 ***


Note You need to log in before you can comment on or make changes to this bug.