Bug 1571118 - Fail to Generate Kibana DC template
Summary: Fail to Generate Kibana DC template
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.z
Assignee: Matt Bruzek
QA Contact: Anping Li
URL:
Whiteboard:
: 1571152 (view as bug list)
Depends On:
Blocks: 1571152
TreeView+ depends on / blocked
 
Reported: 2018-04-24 06:56 UTC by Anping Li
Modified: 2018-07-30 19:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The code had invalid syntax for the variable openshift_logging_master_public_url. Consequence: When users tried to run an install with logging an AnsibleError was generated. Fix: The code uses parentheses in the proper location making the variable assignment valid. Result: The openshift_logging_master_public_url variable now gets a proper default value.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:17 UTC

Description Anping Li 2018-04-24 06:56:04 UTC
Description of problem:
The logging deploy failed at task Generate Kibana DC template. The root cause is typo in /usr/share/ansible/openshift-ansible/roles/openshift_logging/defaults/main.yml.


Version-Release number of selected component (if applicable):
ose-ansible/images/v3.10.0-0.28.0.0


How reproducible:
always

Steps to Reproduce:
1. deploy logging
2.
3.

Actual results:
ASK [openshift_logging_kibana : Generate Kibana DC template] ******************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_logging_kibana/tasks/main.yaml:240
Tuesday 24 April 2018  06:24:41 +0000 (0:00:00.673)       0:01:35.488 ********* 
fatal: [ec2-34-229-233-101.compute-1.amazonaws.com]: FAILED! => {
    "changed": false, 
    "msg": "AnsibleError: {{ openshift_logging_master_public_url }}: {{ 'https://' + openshift_master_cluster_public_hostname | default(openshift.common.public_hostname) + ':' ~ openshift_master_api_port) }}: template error while templating string: unexpected ')'. String: {{ 'https://' + openshift_master_cluster_public_hostname | default(openshift.common.public_hostname) + ':' ~ openshift_master_api_port) }}"
}

RUNNING HANDLER [openshift_logging_elasticsearch : Restarting logging-{{ _cluster_component }} cluster] ***
Tuesday 24 April 2018  06:24:41 +0000 (0:00:00.100)       0:01:35.588 ********* 

RUNNING HANDLER [openshift_logging_elasticsearch : set_fact] *******************
Tuesday 24 April 2018  06:24:41 +0000 (0:00:00.000)       0:01:35.588 ********* 

PLAY RECAP *********************************************************************
ec2-18-232-104-227.compute-1.amazonaws.com : ok=0    changed=0    unreachable=0    failed=0   
ec2-34-229-233-101.compute-1.amazonaws.com : ok=180  changed=25   unreachable=0    failed=1   
ec2-54-172-163-240.compute-1.amazonaws.com : ok=0    changed=0    unreachable=0    failed=0   
localhost                  : ok=13   changed=0    unreachable=0    failed=0   


Expected results:
Logging can be deployed

Additional info:

Comment 1 Anping Li 2018-04-24 08:47:44 UTC
*** Bug 1571152 has been marked as a duplicate of this bug. ***

Comment 2 Matt Bruzek 2018-04-24 14:15:56 UTC
I created a PR to address this problem here: https://github.com/openshift/openshift-ansible/pull/8097

Comment 4 Junqi Zhao 2018-05-17 07:48:14 UTC
Issue is fixed, could generate Kibana DC template now

# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.10.0-0.47.0.git.0.c018c8f.el7.noarch
openshift-ansible-docs-3.10.0-0.47.0.git.0.c018c8f.el7.noarch
openshift-ansible-playbooks-3.10.0-0.47.0.git.0.c018c8f.el7.noarch
openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch

Comment 6 errata-xmlrpc 2018-07-30 19:13:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.