Bug 1571136 - [abrt] gjs: _cairo_hash_table_destroy(): gjs-console killed by SIGABRT
Summary: [abrt] gjs: _cairo_hash_table_destroy(): gjs-console killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gjs
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9872f0d14748b33e7ca234666d2...
: 1571201 (view as bug list)
Depends On:
Blocks: F28FinalBlocker F28FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-04-24 07:30 UTC by Chris Murphy
Modified: 2018-04-25 00:02 UTC (History)
10 users (show)

Fixed In Version: gjs-1.52.2-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 00:02:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (31.90 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: cgroup (399 bytes, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: core_backtrace (12.06 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: cpuinfo (1.06 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: dso_list (8.99 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: environ (5.44 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: maps (43.70 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: mountinfo (3.96 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: open_fds (1.73 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
File: proc_pid_status (1.26 KB, text/plain)
2018-04-24 07:30 UTC, Chris Murphy
no flags Details
gjs coredumpctl gdb (16.44 KB, text/plain)
2018-04-24 07:38 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2018-04-24 07:30:42 UTC
Description of problem:


Version-Release number of selected component:
gjs-1.52.1-1.fc28

Additional info:
reporter:       libreport-2.9.4
backtrace_rating: 3
cmdline:        /usr/bin/gjs-console /usr/share/anaconda/gnome/fedora-welcome
crash_function: _cairo_hash_table_destroy
executable:     /usr/bin/gjs-console
journald_cursor: s=7e3e53728f39496891c5523f823c5e18;i=1e6c;b=819681d38b974c0ba2c542cc52632791;m=54cddaa;t=56a92fa5c8c14;x=b4048a4b08de9807
kernel:         4.16.2-300.fc28.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Chris Murphy 2018-04-24 07:30:47 UTC
Created attachment 1425832 [details]
File: backtrace

Comment 2 Chris Murphy 2018-04-24 07:30:48 UTC
Created attachment 1425833 [details]
File: cgroup

Comment 3 Chris Murphy 2018-04-24 07:30:49 UTC
Created attachment 1425834 [details]
File: core_backtrace

Comment 4 Chris Murphy 2018-04-24 07:30:50 UTC
Created attachment 1425835 [details]
File: cpuinfo

Comment 5 Chris Murphy 2018-04-24 07:30:51 UTC
Created attachment 1425836 [details]
File: dso_list

Comment 6 Chris Murphy 2018-04-24 07:30:52 UTC
Created attachment 1425837 [details]
File: environ

Comment 7 Chris Murphy 2018-04-24 07:30:53 UTC
Created attachment 1425838 [details]
File: limits

Comment 8 Chris Murphy 2018-04-24 07:30:55 UTC
Created attachment 1425839 [details]
File: maps

Comment 9 Chris Murphy 2018-04-24 07:30:56 UTC
Created attachment 1425840 [details]
File: mountinfo

Comment 10 Chris Murphy 2018-04-24 07:30:57 UTC
Created attachment 1425841 [details]
File: open_fds

Comment 11 Chris Murphy 2018-04-24 07:30:58 UTC
Created attachment 1425842 [details]
File: proc_pid_status

Comment 12 Chris Murphy 2018-04-24 07:38:03 UTC
Created attachment 1425843 [details]
gjs coredumpctl gdb

This is the coredumpctl gdb version, which had me download a bunch of additional debuginfo and debugsource files, which abrt didn't. *shrug*

Comment 13 Chris Murphy 2018-04-24 07:43:58 UTC
Cute the description didn't get saved...

When booting from Fedora-Workstation-Live-x86_64-28-20180423.n.0.iso, at the desktop is "Welcome to Fedora" and I click the "Install to Hard Drive" option. Soon after that there's a crash notification for fedora-welcome. But in the live environment I run into a problem either with retrace server doing the backtrace
https://github.com/abrt/retrace-server/issues/188 or doing it locally due to lack of resources in the live environment. Therefore to reproduce:

1. install using default layout
2. run through g-i-s to create a user
3. login and reboot
4. open terminal and run

[chris@localhost-live ~]$ /usr/share/anaconda/gnome/fedora-welcome 

5. click on "Install to Hard Drive"
crash

Comment 14 Fedora Blocker Bugs Application 2018-04-24 07:46:23 UTC
Proposed as a Blocker for 28-final by Fedora user chrismurphy using the blocker tracking app because:

 "Basic functionality means that the app must at least be broadly capable of its most basic expected operations, and that it must not crash without user intervention or with only basic user intervention."

It does work, but it also crashes.

Comment 15 Chris Murphy 2018-04-24 08:03:21 UTC
This seems to fix it gjs-1.52.2-1.fc28.kalev0.x86_64.rpm which I got from https://koji.fedoraproject.org/koji/taskinfo?taskID=26450574 and seemingly unrelated (per the stack trace anyway) bug
https://gitlab.gnome.org/GNOME/gjs/issues/148#note_98619

Comment 16 Kalev Lember 2018-04-24 08:50:05 UTC
gjs 1.52.2 (https://bodhi.fedoraproject.org/updates/FEDORA-2018-78aeb849b8) was released shortly after 1.52.1 (that's the version in F27 stable right now) to fix a crash in cairo data destroy. It sounds a lot like this is the exact crash you are hitting with fedora-welcome when it's exiting.

Could you please check if regular 1.52.2 fixes the crash as well (not the kalev0 version?)

Comment 17 Kalev Lember 2018-04-24 08:51:32 UTC
Also, did you deliberately un-propose it as a blocker? I think it should be a FE at least if fedora-welcome is occasionally crashing.

Comment 18 Lukas Ruzicka 2018-04-24 12:22:58 UTC
*** Bug 1571201 has been marked as a duplicate of this bug. ***

Comment 19 Kalev Lember 2018-04-24 13:13:52 UTC
I just tested it here and verified that gjs-1.52.2-1.fc28 fixes the crash on exit.

Comment 20 Fedora Update System 2018-04-24 13:14:23 UTC
gjs-1.52.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-78aeb849b8

Comment 21 Adam Williamson 2018-04-24 15:23:23 UTC
Oh yeah, I've seen it crash on exit several times in testing. When I tried to reproduce it to report it, though, it wouldn't crash, of course...

On the one hand I would -1 blocker this on the "basic functionality" criterion as all the actual 'functionality' of the welcome window works, it just crashes on exit. But there's a reasonable case for +1 on the criterion "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop", as it's very hard to do a Workstation live install without causing the welcome window to exit in some way, at which point it's highly likely this crash will occur, it seems...

Comment 22 Chris Murphy 2018-04-24 16:00:20 UTC
+1 blocker, at least for me it crashes every time, and there's a crash notification in between clicking on "Install" and the anaconda language page appearing.

1. Boot live with '3'
2. scp gjs-1.52.2-1.fc28.x86_64.rpm over and rpm -U it
3. systemctl isolate graphical
4. click "Install..."
no crash

Comment 23 Stephen Gallagher 2018-04-24 17:18:04 UTC
-1 blocker from me on the grounds that I strongly doubt we wouldn't fudge this at a Go/No-Go meeting.

That said, I'd be willing to accept it as a Freeze Exception.

Comment 24 Adam Williamson 2018-04-24 17:52:03 UTC
I'm +1 FE too obviously, so we clearly have at least enough votes to accept it as FE at this point.

Comment 25 Mohan Boddu 2018-04-24 19:29:59 UTC
Definitely +1 FE, not sure if I call it as blocker or not.

Comment 26 Fedora Update System 2018-04-25 00:02:20 UTC
gjs-1.52.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.