Bug 1571144 - Links from system dashboard not working.
Summary: Links from system dashboard not working.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: Core
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Vojtech Szocs
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 07:43 UTC by Yaniv Lavi
Modified: 2018-05-14 07:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:34:01 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
ylavi: blocker+
pnovotny: testing_plan_complete+
mgoldboi: planning_ack+
gshereme: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90657 master MERGED Modify applySearch to ensure api.revealPlace() call 2018-04-25 20:09:33 UTC
oVirt gerrit 90658 ovirt-engine-dashboard-1.2 MERGED Modify applySearch to ensure api.revealPlace() call 2018-04-25 20:47:32 UTC

Description Yaniv Lavi 2018-04-24 07:43:34 UTC
Description of problem:
When you click on entities on the dashboard you used to jump to the correct tab with the filter applied. This is no longer working with the new UX in 4.2.

Version-Release number of selected component (if applicable):
4.2.3-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Open WebAdmin
2. Click on clusters / storage domains/ entities in reports on the CPU, memory and storage widgets

Actual results:
Nothing happens, switching to other relevant tabs has filter applied. 

Expected results:
Jump to tab with filter applied. 

Additional info:

Comment 1 Vojtech Szocs 2018-04-26 14:30:51 UTC
Please note that there are two types of bugs to verify:

1, (as reported in BZ description) Clicking on heat map blocks (under Cluster Utilization and Storage Utilization) should take you to the corresponding grid view, with search applied.

2, In the resource utilization dialog, clicking on Host and VM links (under CPU and Memory) as well as Storage and VM links (under Storage) should take you to the corresponding grid view, with search applied.

Comment 2 Lucie Leistnerova 2018-04-27 09:38:58 UTC
All links from dashboard (status cards, donut charts dialogs, cluster/storage utilization boxes) goes to proper grid view.

There is only one little problem with Gluster Volumes status card, I created new BZ 1572539.

verified in ovirt-engine-dashboard-1.2.3-2.el7ev.noarch, ovirt-engine-4.2.3.3-0.1.el7.noarch

Comment 3 Sandro Bonazzola 2018-05-10 06:34:01 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Comment 4 Yaniv Kaul 2018-05-14 06:55:03 UTC
(In reply to Lucie Leistnerova from comment #2)
> All links from dashboard (status cards, donut charts dialogs,
> cluster/storage utilization boxes) goes to proper grid view.
> 
> There is only one little problem with Gluster Volumes status card, I created
> new BZ 1572539.
> 
> verified in ovirt-engine-dashboard-1.2.3-2.el7ev.noarch,
> ovirt-engine-4.2.3.3-0.1.el7.noarch

I'm still seeing this - for example in the storage pie popup, the links do not jump to the VMs or Storage domains. Can you check?

Comment 5 Lucie Leistnerova 2018-05-14 07:15:11 UTC
Links from storage donut chart popup work and go to proper storage/VM (and so the others).
I have newest QE 4.2 d/s build
ovirt-engine-4.2.3.5-0.1.el7.noarch with ovirt-engine-dashboard-1.2.3-2.el7ev.noarch


Note You need to log in before you can comment on or make changes to this bug.