Bug 1571213 - [abrt] __ieee80211_flush_queues: WARNING: CPU: 1 PID: 8695 at drivers/net/wireless/intel/iwlwifi/dvm/../iwl-trans.h:1040 iwlagn_mac_flush+0x159/0x1b0 [iwldvm] [mac80211]
Summary: [abrt] __ieee80211_flush_queues: WARNING: CPU: 1 PID: 8695 at drivers/net/wir...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a621cdfe15148a79a060414013b...
: 1575681 1582895 1601073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 10:26 UTC by Or Schiro
Modified: 2018-11-05 16:36 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-05 16:36:08 UTC
Type: ---


Attachments (Terms of Use)
File: dmesg (71.67 KB, text/plain)
2018-04-24 10:27 UTC, Or Schiro
no flags Details

Description Or Schiro 2018-04-24 10:26:46 UTC
Additional info:
reporter:       libreport-2.9.4
WARNING: CPU: 1 PID: 8695 at drivers/net/wireless/intel/iwlwifi/dvm/../iwl-trans.h:1040 iwlagn_mac_flush+0x159/0x1b0 [iwldvm]
Modules linked in: snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_dummy fuse ccm nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables sunrpc intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel wmi_bmof kvm arc4 mei_wdt iTCO_wdt iTCO_vendor_support iwldvm irqbypass crct10dif_pclmul mac80211 crc32_pclmul ghash_clmulni_intel intel_cstate intel_uncore uvcvideo intel_rapl_perf videobuf2_vmalloc
 videobuf2_memops videobuf2_v4l2 iwlwifi videobuf2_common videodev snd_hda_codec_hdmi joydev cfg80211 snd_hda_codec_realtek media snd_hda_codec_generic snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_seq snd_seq_device snd_pcm wmi thinkpad_acpi tpm_tis tpm_tis_core snd_timer rfkill tpm mei_me snd i2c_i801 mei lpc_ich soundcore shpchp i915 crc32c_intel i2c_algo_bit drm_kms_helper serio_raw drm sdhci_pci e1000e cqhci sdhci mmc_core ptp pps_core video
CPU: 1 PID: 8695 Comm: kworker/u16:2 Not tainted 4.16.3-300.fc28.x86_64 #1
Hardware name: LENOVO 23352CG/23352CG, BIOS G2ETB2WW (2.72 ) 04/11/2018
Workqueue: phy0 ieee80211_iface_work [mac80211]
RIP: 0010:iwlagn_mac_flush+0x159/0x1b0 [iwldvm]
RSP: 0018:ffffaea309163c58 EFLAGS: 00010297
RAX: ffffffffc06b2a90 RBX: ffff9f8288f01520 RCX: ffffffffc084a7d0
RDX: 0000000000000000 RSI: 0000000080000000 RDI: ffff9f8281150028
RBP: 00000000000ffdef R08: ffffffffc0853800 R09: 0000000000000000
R10: 00000000000003ff R11: 0000000000000003 R12: ffff9f8288f01560
R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
FS:  0000000000000000(0000) GS:ffff9f829e240000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00003cd5134f4598 CR3: 000000007720a004 CR4: 00000000001606e0
Call Trace:
 __ieee80211_flush_queues+0xad/0x1b0 [mac80211]
 __ieee80211_recalc_idle+0xad/0x110 [mac80211]
 ieee80211_recalc_idle+0x10/0x30 [mac80211]
 ieee80211_free_chanctx+0xa3/0xc0 [mac80211]
 __ieee80211_vif_release_channel+0xed/0x130 [mac80211]
 ieee80211_vif_release_channel+0x3a/0x50 [mac80211]
 ieee80211_set_disassoc+0x27f/0x3b0 [mac80211]
 ieee80211_sta_connection_lost.constprop.24+0x36/0x70 [mac80211]
 ieee80211_sta_work+0x246/0x5e0 [mac80211]
 ? set_next_entity+0x96/0x1c0
 ? skb_dequeue+0x52/0x60
 ? process_one_work+0x187/0x340
 process_one_work+0x187/0x340
 worker_thread+0x2e/0x380
 ? pwq_unbound_release_workfn+0xd0/0xd0
 kthread+0x112/0x130
 ? kthread_create_worker_on_cpu+0x70/0x70
 ? do_syscall_64+0x74/0x180
 ? SyS_exit_group+0x10/0x10
 ret_from_fork+0x35/0x40
Code: f6 e8 2c 2c e7 ff eb 89 48 8b 7b 10 49 c7 c0 b8 37 85 c0 31 d2 be 00 00 80 00 48 c7 c1 d0 a7 84 c0 e8 9c 2c e7 ff e9 66 ff ff ff <0f> 0b 48 8b 7f 30 49 c7 c0 b0 a7 84 c0 31 d2 31 f6 48 c7 c1 3b 

Potential duplicate: bug 1567288

Comment 1 Or Schiro 2018-04-24 10:27:05 UTC
Created attachment 1425895 [details]
File: dmesg

Comment 2 Or Schiro 2018-05-07 15:24:26 UTC
*** Bug 1575681 has been marked as a duplicate of this bug. ***

Comment 3 strasharo2000 2018-05-11 10:22:58 UTC
Description of problem:
Just regular browsing, did no specific action.

Version-Release number of selected component:
kernel-core-4.16.7-300.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        BOOT_IMAGE=/vmlinuz-4.16.7-300.fc28.x86_64 root=/dev/mapper/fedora_t99-root ro rd.lvm.lv=fedora_t99/root rd.luks.uuid=luks-5264373e-3cc0-4aaf-a840-2e6181fb7b5b rd.lvm.lv=fedora_t99/swap rhgb quiet libata.allow_tpm=1 LANG=en_US.UTF-8
crash_function: __ieee80211_flush_queues
kernel:         4.16.7-300.fc28.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 7798 at drivers/net/wireless/intel/iwlwifi/dvm/../iwl-trans.h:1040 iwlagn_mac_flush+0x159/0x1b0 [iwldvm]
Modules linked in: ccm bnep xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun fuse ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack devlink ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables sunrpc btusb btrtl btbcm btintel bluetooth coretemp kvm_intel ecdh_generic snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_codec_generic kvm mei_wdt snd_hda_intel iTCO_wdt iTCO_vendor_support arc4 wmi_bmof iwldvm uvcvideo snd_hda_codec mac80211 videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common
 snd_hda_core irqbypass snd_hwdep iwlwifi videodev snd_seq media i2c_i801 r592 joydev cfg80211 memstick snd_seq_device snd_pcm mei_me lpc_ich thinkpad_acpi mei snd_timer wmi snd tpm_tis tpm_tis_core soundcore rfkill tpm acpi_cpufreq shpchp binfmt_misc dm_crypt i915 radeon mmc_block sdhci_pci cqhci sdhci i2c_algo_bit drm_kms_helper mmc_core serio_raw ttm firewire_ohci firewire_core yenta_socket e1000e crc_itu_t drm ptp pps_core video
CPU: 1 PID: 7798 Comm: kworker/u8:2 Not tainted 4.16.7-300.fc28.x86_64 #1
Hardware name: LENOVO 4061W4Y/4061W4Y, BIOS 6FET93WW (3.23 ) 10/12/2012
Workqueue: phy0 ieee80211_iface_work [mac80211]
RIP: 0010:iwlagn_mac_flush+0x159/0x1b0 [iwldvm]
RSP: 0018:ffffafa60388fc58 EFLAGS: 00010297
RAX: ffffffffc0bc2a90 RBX: ffff8d3b8e3f9520 RCX: ffffffffc0da07d0
RDX: 0000000000000000 RSI: 0000000080000000 RDI: ffff8d3b904d0028
RBP: 00000000000ffdef R08: ffffffffc0da9800 R09: 0000000000000000
R10: 00000000000003ff R11: 0000000000000000 R12: ffff8d3b8e3f9560
R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
FS:  0000000000000000(0000) GS:ffff8d3b9bc80000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00001146fd37ceb0 CR3: 000000021620a000 CR4: 00000000000006e0
Call Trace:
 __ieee80211_flush_queues+0xad/0x1b0 [mac80211]
 __ieee80211_recalc_idle+0xad/0x110 [mac80211]
 ieee80211_recalc_idle+0x10/0x30 [mac80211]
 ieee80211_free_chanctx+0xa3/0xc0 [mac80211]
 __ieee80211_vif_release_channel+0xed/0x130 [mac80211]
 ieee80211_vif_release_channel+0x3a/0x50 [mac80211]
 ieee80211_set_disassoc+0x27f/0x3b0 [mac80211]
 ieee80211_sta_connection_lost.constprop.24+0x36/0x70 [mac80211]
 ieee80211_sta_work+0x246/0x5e0 [mac80211]
 ? account_entity_dequeue+0xa4/0xd0
 ? dequeue_entity+0xd9/0x400
 ? pick_next_task_fair+0x332/0x590
 ? __switch_to+0xa3/0x4b0
 ? skb_dequeue+0x52/0x60
 ? process_one_work+0x187/0x340
 process_one_work+0x187/0x340
 worker_thread+0x2e/0x380
 ? pwq_unbound_release_workfn+0xd0/0xd0
 kthread+0x112/0x130
 ? kthread_create_worker_on_cpu+0x70/0x70
 ? do_syscall_64+0x74/0x180
 ? SyS_exit_group+0x10/0x10
 ret_from_fork+0x35/0x40
Code: f6 e8 2c cc e2 ff eb 89 48 8b 7b 10 49 c7 c0 b8 97 da c0 31 d2 be 00 00 80 00 48 c7 c1 d0 07 da c0 e8 9c cc e2 ff e9 66 ff ff ff <0f> 0b 48 8b 7f 30 49 c7 c0 b0 07 da c0 31 d2 31 f6 48 c7 c1 3b

Comment 4 eric 2018-05-27 17:52:48 UTC
*** Bug 1582895 has been marked as a duplicate of this bug. ***

Comment 5 adam.pietrzyk93@gmail.com 2018-07-13 19:25:52 UTC
*** Bug 1601073 has been marked as a duplicate of this bug. ***

Comment 6 Laura Abbott 2018-10-01 21:24:04 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 7 Or Schiro 2018-11-05 16:36:08 UTC
No longer an issue for me with Fedora 28.


Note You need to log in before you can comment on or make changes to this bug.