Bug 1571225 - [RFE] Enable SSL for ceph RDOS using director
Summary: [RFE] Enable SSL for ceph RDOS using director
Keywords:
Status: CLOSED DUPLICATE of bug 1701416
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ceph
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 10:57 UTC by Petersingh Anburaj
Modified: 2021-06-10 15:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-19 13:01:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petersingh Anburaj 2018-04-24 10:57:21 UTC
Description of problem:
Want to enable SSL for ceph RDOS gateway using director deployment.


Steps to Reproduce:
1. Deploy RHOSP with ceph object gateway and SSL.


This should enable SSL for ceph RDOS gateway.

Comment 3 Giulio Fidente 2019-03-13 15:01:13 UTC
In this scenario you're configuring SSL on the public endpoints only, the communication up to the balancer is encrypted and for that purpose the configuration looks correct to me.

Did you intend to propose having the second half of the channel, up to the RGW service, encrypted as well?

Comment 4 Giulio Fidente 2019-06-19 13:01:56 UTC

*** This bug has been marked as a duplicate of bug 1701416 ***


Note You need to log in before you can comment on or make changes to this bug.