Bug 1571246 - One item missing transaction in appliance_console
Summary: One item missing transaction in appliance_console
Keywords:
Status: CLOSED DUPLICATE of bug 1559748
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Joe Rafaniello
QA Contact: Dave Johnson
URL:
Whiteboard: appliance:console
Depends On:
Blocks: 1563745
TreeView+ depends on / blocked
 
Reported: 2018-04-24 11:55 UTC by Matouš Mojžíš
Modified: 2018-05-02 13:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 15:52:44 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Missing transaction (25.95 KB, image/png)
2018-04-24 11:55 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2018-04-24 11:55:10 UTC
Created attachment 1425978 [details]
Missing transaction

Description of problem:


Version-Release number of selected component (if applicable):
5.9.2.3

How reproducible:
Always

Steps to Reproduce:
1. Go to appliance_console
2.
3.

Actual results:
7) translation missing: en.advanced_settings.db_maintenance

Expected results:


Additional info:

Comment 2 Joe Rafaniello 2018-04-24 19:55:44 UTC
Opened upstream and downstream changes:

https://github.com/ManageIQ/manageiq-appliance_console/pull/37 (will need new version released)

https://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/cfme_productization/merge_requests/596

Comment 3 CFME Bot 2018-04-24 20:03:37 UTC
New commit detected on ManageIQ/manageiq-appliance_console/master:

https://github.com/ManageIQ/manageiq-appliance_console/commit/43b80220abcdfa1ff67218624567fa788423a464
commit 43b80220abcdfa1ff67218624567fa788423a464
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Apr 24 15:38:12 2018 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Apr 24 15:38:12 2018 -0400

    db_maintenance was previously removed from en.yml

    https://bugzilla.redhat.com/show_bug.cgi?id=1571246

    Fixes: translation missing: en.advanced_settings.db_maintenance in
    Advanced Settings menu of the appliance console.

    The DB maintenance menu was removed in:
    https://github.com/ManageIQ/manageiq-appliance_console/pull/32

    It was replaced with:

    https://github.com/ManageIQ/manageiq/pull/16929
    https://github.com/ManageIQ/manageiq/pull/16940

 locales/appliance/en.yml | 1 -
 locales/container/en.yml | 1 -
 2 files changed, 2 deletions(-)

Comment 4 Joe Rafaniello 2018-04-24 20:25:12 UTC
Note, this is only an upstream, gaprindashvili and 5.9 problem.

We'll need a tag for appliance_console and bump the appliance_console version

Comment 5 Joe Rafaniello 2018-04-24 20:39:12 UTC
Opened PR to bump appliance to use the not yet released 2.0.1 appliance console:
https://github.com/ManageIQ/manageiq-appliance/pull/188

Comment 6 CFME Bot 2018-04-25 18:19:41 UTC
New commit detected on ManageIQ/manageiq-appliance/master:

https://github.com/ManageIQ/manageiq-appliance/commit/69369acd369c6d2c31a03002e6d1d65a64ba9474
commit 69369acd369c6d2c31a03002e6d1d65a64ba9474
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Apr 24 16:34:20 2018 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Apr 24 16:34:20 2018 -0400

    Bump appliance_console for db_maintenance fix

    https://bugzilla.redhat.com/show_bug.cgi?id=1571246

    Bump the version so we can get this fix:
    https://github.com/ManageIQ/manageiq-appliance_console/pull/37

 manageiq-appliance-dependencies.rb | 4 +-
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 7 Joe Rafaniello 2018-04-25 18:23:15 UTC
Note, this is only an upstream, gaprindashvili and 5.9 problem.
(we don't need 5.8 clones)

Comment 8 Yuri Rudman 2018-04-30 19:28:24 UTC
*** Bug 1559748 has been marked as a duplicate of this bug. ***

Comment 9 Satoe Imaishi 2018-05-01 15:52:44 UTC

*** This bug has been marked as a duplicate of bug 1559748 ***


Note You need to log in before you can comment on or make changes to this bug.