Bug 1571266 - PPC64: cannot create DVD images including backup and cannot split DVD images
Summary: PPC64: cannot create DVD images including backup and cannot split DVD images
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear   
(Show other bugs)
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
Marie Dolezelova
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1596182
TreeView+ depends on / blocked
 
Reported: 2018-04-24 12:23 UTC by Renaud Métrich
Modified: 2018-10-30 11:44 UTC (History)
6 users (show)

Fixed In Version: rear-2.4-1.el7
Doc Type: Release Note
Doc Text:
Rear includes backup archive in the rescue CD ISO image Previously, Relax-and-Recover (ReaR) did not include the backup archive in the rescue CD ISO image when run on the IBM Power Systems architecture. As a consequence, rescue CDs could not be used for restoring the system when the internal backup method was used. This update adds the backup archive into the rescue CD ISO image. As a result, rescue CDs can now be used to restore the system with internal backup method.
Story Points: ---
Clone Of:
: 1596182 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:43:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3293 None None None 2018-10-30 11:44 UTC
Red Hat Bugzilla 1478584 None CLOSED Rear backup archive not getting included in the ISO for ppc64. 2019-02-11 06:59 UTC
Red Hat Knowledge Base (Solution) 3422221 None None None 2018-04-24 13:22 UTC

Internal Trackers: 1478584

Description Renaud Métrich 2018-04-24 12:23:13 UTC
Description of problem:

It appears that there is no code in /usr/share/rear/output/ISO/Linux-ppc64le/ ana /usr/share/rear/output/ISO/Linux-ppc64/ to include the backup in the ISO, when using the following configuration:

OUTPUT=ISO
OUTPUT_URL=file:///home/backup/
BACKUP=NETFS
BACKUP_URL=iso:///OS

Also, the code used to split DVDs is not present.


Version-Release number of selected component (if applicable):

rear-2.00


How reproducible:

Always


Steps to Reproduce:
1. Configure rear as shown above
2. Create backup: "rear mkbackup"
3. Check resulting ISO

Actual results:

No OS/backup.tar.gz file in the ISO


Additional info:

The code has been integrated into rear-2.2

Comment 3 Pavel Cahyna 2018-04-24 12:56:34 UTC
is it related to bz1478584 ?

Comment 4 Renaud Métrich 2018-04-24 13:23:05 UTC
It is, wasn't aware of

Comment 18 Pavel Cahyna 2018-06-27 16:22:58 UTC
merged upstream in 2.2/7124c122f855d83f0e7d373416ed95bc3d9e0cbb

Comment 25 errata-xmlrpc 2018-10-30 11:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3293


Note You need to log in before you can comment on or make changes to this bug.