Bug 1571285 - RAW-Preallocated file-based disk convert to raw-sparse after cold migrating it to another storage domain
Summary: RAW-Preallocated file-based disk convert to raw-sparse after cold migrating i...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.3.3
: ---
Assignee: Eyal Shenitzky
QA Contact: Evelina Shames
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 12:50 UTC by Eyal Shenitzky
Modified: 2019-04-16 13:58 UTC (History)
6 users (show)

Fixed In Version: vdsm-4.30.12, ovirt-engine-4.3.3.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 13:58:19 UTC
oVirt Team: Storage
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 86281 0 master MERGED copy_data: Keep volume preallocation 2020-08-03 08:33:03 UTC
oVirt gerrit 86282 0 master ABANDONED fileVolume: Allow deferring volume preallocation 2020-08-03 08:33:03 UTC
oVirt gerrit 90090 0 master MERGED core: consume file-based volumes deferred preallocation 2020-08-03 08:33:03 UTC
oVirt gerrit 93557 0 master MERGED fileVolume: Allow deferring volume preallocation 2020-08-03 08:33:03 UTC
oVirt gerrit 98413 0 ovirt-4.3 MERGED localfssd_test: extract create domain logic tmprepo.py 2020-08-03 08:33:04 UTC
oVirt gerrit 98414 0 ovirt-4.3 MERGED formatconverter_tests: use tmprepo create_localfs_domain() 2020-08-03 08:33:04 UTC
oVirt gerrit 98538 0 ovirt-4.3 MERGED localfssd_test: add tests for LocalFsSD.createVolume() 2020-08-03 08:33:04 UTC
oVirt gerrit 98539 0 ovirt-4.3 MERGED localfssd_test: add tests for creating volumes with initial size 2020-08-03 08:33:04 UTC
oVirt gerrit 98540 0 ovirt-4.3 MERGED localfssd_test: add metadata verification for volume creation tests 2020-08-03 08:33:04 UTC
oVirt gerrit 98541 0 ovirt-4.3 MERGED fileVolume: extract file truncation to a helper method 2020-08-03 08:33:04 UTC
oVirt gerrit 98542 0 ovirt-4.3 MERGED fileVolume: extract file allocation to a helper method 2020-08-03 08:33:05 UTC
oVirt gerrit 98543 0 ovirt-4.3 MERGED fileVolume: extract set file permission to a helper method 2020-08-03 08:33:05 UTC
oVirt gerrit 98589 0 ovirt-4.3 MERGED fileVolume: split _create() to raw and cow volume creation helpers 2020-08-03 08:33:05 UTC
oVirt gerrit 98590 0 ovirt-4.3 MERGED fileVolume: change _create() helpers to pep8 code style 2020-08-03 08:33:05 UTC
oVirt gerrit 98591 0 ovirt-4.3 MERGED fileVolume: use bytes instead of blocks in _create() helpers 2020-08-03 08:33:05 UTC
oVirt gerrit 98638 0 ovirt-4.3 MERGED fileVolume: Allow deferring volume preallocation 2020-08-03 08:33:05 UTC
oVirt gerrit 98659 0 ovirt-engine-4.3 MERGED core: consume file-based volumes deferred preallocation 2020-08-03 08:33:06 UTC

Description Eyal Shenitzky 2018-04-24 12:50:06 UTC
Description of problem:

When cold migrating raw-preallocated file-based disk to a different file-based storage domain, the new disk create as RAW-Sparse instead of RAW-Preallocated.

After migrating the disk, it presented as "thin-provisioned" disk instead of "preallocated" and the disk actual size not equal to its provisional size (using qemu-img info).

There are two reasons for this bug:
1. The engine instructs the VDSM to create the raw-preallocated file-based disk as "sparse".
2. The vdsm use 'qemu-img convert' without the preallocation option (FALLOC).

Version-Release number of selected component (if applicable):
master-4.3.0 - from commit dd5c57f39e9ba031ae7abb734c33ee89965cc21c

How reproducible:
100%

Steps to Reproduce:
1. Create 2 GB raw-preallocated file-based disk
2. Migrate the disk from step 1 to different file-based disk

Actual results:
The disk becomes "thin-provisioned"

Expected results:
The disk should remain as "preallocated"

Additional info:

Comment 1 Eyal Shenitzky 2018-04-24 12:51:20 UTC
Relevant also when migrating preallocated block-based disk to file storage domain

Comment 2 Yaniv Kaul 2018-04-30 07:32:29 UTC
Severity?

Comment 3 Sandro Bonazzola 2019-01-28 09:34:26 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 4 Evelina Shames 2019-04-02 11:12:45 UTC
Verified on engine 4.3.3.1-0.1.

Comment 5 Sandro Bonazzola 2019-04-16 13:58:19 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.