Bug 157129 - mknod failed errors before system boot
mknod failed errors before system boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 158427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-07 04:23 EDT by cameleon078
Modified: 2015-01-04 17:19 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 14:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cameleon078 2005-05-07 04:23:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
The 3 messages are written after "Init version ..." and before "Press I for interactive boot" :
mknod failed to create console 17
mknod failed to create null 17
mknod failed to create zero 17

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1286_FC4

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 4 Test 2
2.yum update
3.
  

Additional info:
Comment 1 cameleon078 2005-05-07 05:10:48 EDT
In fact the messages are written after "Red Hat Nash version ..." and before
"Init version ...".
Comment 2 David Nedrow 2005-06-17 13:42:57 EDT
This continues to occur in the release version of Core 4, though it still does
not appear to be anything other than cosmetic. Has anyone actually seen an
instance where there in fact is no device node for the errored devices?

Also, I would suggest updating the version number for this bug to FC4.
Comment 3 Alexandre Oliva 2005-06-17 14:57:53 EDT
*** Bug 158427 has been marked as a duplicate of this bug. ***
Comment 4 Arthur Pemberton 2005-06-21 01:34:19 EDT
I am running a fresh FC4 install, downloaded from the official torrent. I am
getting these same errors, yet these files do exist.
Comment 5 Neil Bezuidenhout 2005-06-22 02:02:58 EDT
I had the same messages with the final release of FC4, but the last update of
the selinux packages (1.23.18-12) seems to have cured the problem.
Comment 6 Ronny Nussbaum 2005-06-23 11:32:06 EDT
I'm on FC4 Final, SElinux disabled, and the error still occurs.
System is fully updated.

-RoNNY
Comment 7 Dave Jones 2005-06-27 19:25:58 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 8 Ronny Nussbaum 2005-06-27 21:07:55 EDT
I'm not sure I understand that last message Dave.
What is it that you want done exactly?

Thanks

-RoNNY
Comment 9 David Nedrow 2005-06-27 23:10:08 EDT
Dave J.,

To confirm, the errors reported for this bug continue to occur in the release version of FC4.

-David N.
Comment 10 Ronny Nussbaum 2005-06-27 23:20:58 EDT
OK. So apparently I did understand what Dave J. asked for.
David is correct. FC4 *FINAL* (as I wrote above), still has the bugs.
Fully updated FC4.

-RoNNY
Comment 11 Sergio Monteiro Basto 2005-07-07 11:59:17 EDT
Confirm the same here 
well after start X with startx or kdm or gdm, my console becames with wrong
format with some blue on background , kdm doesn't start correctly always show a
default blue screen with login that I am not what I am asking for.

have you some workarround for this bug ? 
Comment 12 Dave Jones 2005-07-07 19:02:58 EDT
the console corruption is likely bug 161242

I still have no explanation for the original bug reported here.  Was the
mkinitrd package up to date when the kernel was installed ?
Comment 13 Alexandre Oliva 2005-07-07 22:15:23 EDT
the problem happened after an FC4 install from scratch, and there hasn't been
any update to mkinitrd in FC4.  So, yes, it's up to date.  And, really, there's
not a lot of room for changes in the sequence that starts with udevstart and is
immediately followed by the mknods that fail.
Comment 14 Neil Bezuidenhout 2005-07-11 04:07:28 EDT
In my previous post I wrote that the mknod issue seems to be resolved. However
it now appears to be almost random. On some reboots I do not receive the error,
but sometimes it is there. The same goes for when the PC is switched on or when
I had to do a hard reset.

Further, referring to comment #12, sometimes I cannot access the text consoles
using Ctrl-Alt-F1. The X window (gnome @ 1280x1024) simply changes size, locks
and places itself in the top-left of the screen (@ 1600x1200).
Comment 15 Dave Jones 2005-07-15 17:43:32 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 16 Ronny Nussbaum 2005-07-20 20:18:50 EDT
This fixed the issue for me.

-RoNNY
Comment 17 Igor Bukanov 2005-08-09 06:40:02 EDT
I got the same problem on old Sony Vaio PCG-Z505R notebook. I did a fresh
install of FC4, which showed the problem. After "yum update" which brought
kernel to 2.6.12-1.1398_FC4, nothing changes and again I got during boot:

mknod failed to create console 17
mknod failed to create null 17
mknod failed to create zero 17
Comment 18 liug 2005-08-16 17:30:43 EDT
Same problem here after upgrading from FC3 to FC4, and yum update to have all
FC4 updates (including kernel) applied.

It seems random in that one some reboots, I don't see the error.
Comment 19 Andreas M. Kirchwitz 2005-08-23 22:00:38 EDT
Same problem here on 3 different machines (P3@600+800 MHz, P4@2,4 GHz).
With initial kernel-2.6.11-1.1369_FC4 (after fresh install,
no custom initrd, everything on ) and updated kernel-2.6.12-1.1398_FC4.

Chances are about 75% that the errors don't appear. And sometimes
not all 3 mknod errors come up but only 2 or 1. Could that be
related to some timing problems during initrd processing?

The only "non-standard" thing on these machines is the software RAID-1
(via DiskDruid) which also caused a kernel panic after first installation
on all machines (right after the final "Reboot" button). But this seems
to be a different story.

Haven't had any of these errors on an AMD AthlonXP 2000 (single harddisk,
no RAID-1).

However, doesn't seem to be harmful. It just doesn't "look" good to
have errors during boot. ;-)
Comment 20 Dave Jones 2005-09-29 21:28:14 EDT
still a problem with the latest errata ?
(Note, there's also another going to be pushed *really* soon, which you can grab
& test at http://people.redhat.com/davej/kernels/Fedora/FC4/ )
Comment 21 Alexandre Oliva 2005-10-28 14:09:47 EDT
I believe this was fixed with a mkinitrd update, that fixed a bug in nash's
wait() for child processes, by which it would not wait for the right child to
complete if any other child completed first.  Or something like that...
Comment 22 Alexandre Oliva 2005-10-28 14:16:13 EDT
See Bug 163407 for the gory details.
Comment 23 Andreas M. Kirchwitz 2005-12-19 04:21:28 EST
Sorry to say that, but today I got the error messages again
with the newest kernel 2.6.14-1.1653_FC4 (and all other updates).
Obviously, it happens very rarely (haven't seen the messages
for weeks). But it looks like the bug is not fixed yet.
Comment 24 nicofo 2006-01-23 14:55:13 EST
Idem with 2.6.14-1.1656_FC4 and up to date packages : this appears 'sometimes',
but it seems to me that it happens more often that before (difficult to say
because quite random) : roughly every 2 / 4 boot.
Comment 25 Erik Terwan 2006-03-16 06:45:52 EST
Problem also appears with kernel 2.6.15-1.1833_FC4 (also random).

Note You need to log in before you can comment on or make changes to this bug.