Bug 1571297 - OSP 13 dpdk deployment fails - ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)
Summary: OSP 13 dpdk deployment fails - ovs-vsctl: unix:/var/run/openvswitch/db.sock: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Saravanan KR
QA Contact: Maxim Babushkin
URL:
Whiteboard:
Depends On:
Blocks: 1573874 1578802
TreeView+ depends on / blocked
 
Reported: 2018-04-24 13:19 UTC by Maxim Babushkin
Modified: 2018-06-27 13:54 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-14.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
dpdk_overcloud_log.txt (496.37 KB, text/plain)
2018-04-24 13:19 UTC, Maxim Babushkin
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1766759 None None None 2018-04-25 02:10:14 UTC
OpenStack gerrit 564384 None MERGED Add volumes list of docker-puppet container when merging config volumes 2020-05-06 13:20:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:54:15 UTC

Description Maxim Babushkin 2018-04-24 13:19:17 UTC
Created attachment 1426059 [details]
dpdk_overcloud_log.txt

Description of problem:
OSP 13 dpdk deployment fails with the error:
ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)


Version-Release number of selected component (if applicable):
OSP 13
Puddle: 2018-04-19.2

Full overcloud log attached.

SOS report will be added shortly.

Comment 1 Saravanan KR 2018-04-24 14:23:17 UTC
Possible fix - https://review.openstack.org/563978
I have patched the undercloud and started a deployment in the screen.

Comment 2 Maxim Babushkin 2018-04-24 16:00:05 UTC
Saravanan,

The fix worked. Thanks.

Comment 3 Saravanan KR 2018-04-25 02:08:45 UTC
(In reply to Maxim Babushkin from comment #2)
> Saravanan,
> 
> The fix worked. Thanks.

Thanks for confirmation. I will proceed with the upstream fix.

Comment 4 Saravanan KR 2018-04-27 04:04:34 UTC
Merged on stable/queens.

Comment 6 Saravanan KR 2018-05-02 06:43:39 UTC
This bug is present from the day one of adding volumes support to the docker-puppet script. But it has been hidden because of the order merging the config volumes. Till earlier puddle config_volume of neutron-ovs-dpdk-agent.yaml before config_volume of neutron-plugin-ml2.yaml, in which case the volumes will be added correctly. In this puddle, config_volume of neutron-plugin-ml2.yaml is merged first, and because of the bug, volumes list in other plugin is ignored. It is hard to find what triggered the order change, but irrespective of the order, the merging should happen correctly.

Comment 12 errata-xmlrpc 2018-06-27 13:52:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.