Bug 1571300 - VdsNotRespondingTreatment releases VDS_FENCE lock twice
Summary: VdsNotRespondingTreatment releases VDS_FENCE lock twice
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Ravi Nori
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 13:23 UTC by Ravi Nori
Modified: 2018-05-10 06:29 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.2.3.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:29:07 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90568 0 master MERGED engine : VdsNotRespondingTreatment releases VDS_FENCE lock twice 2018-04-26 12:25:19 UTC
oVirt gerrit 90694 0 ovirt-engine-4.2 MERGED engine : VdsNotRespondingTreatment releases VDS_FENCE lock twice 2018-04-26 13:14:01 UTC
oVirt gerrit 90701 0 ovirt-engine-4.2.3.z MERGED engine : VdsNotRespondingTreatment releases VDS_FENCE lock twice 2018-04-30 12:07:34 UTC

Description Ravi Nori 2018-04-24 13:23:42 UTC
Description of problem: VdsNotRespondingTreatmentCommand executes SetStoragePoolStatusCommand which releases the VDS_FENCE lock. The lock is again released by VdsNotRespondingTreatmentCommand resulting in warning message in the logs.


Version-Release number of selected component (if applicable): 4.3


How reproducible:


Steps to Reproduce:
1. Have Domain in Up status
2. Shutdown engine
3. Stop vdsm
4. Start engine

Actual results:

VDS_FENCE lock is relased twice

2018-04-24 09:07:05,312-04 WARN  [org.ovirt.engine.core.bll.lock.InMemoryLockManager] (EE-ManagedThreadFactory-engine-Thread-6) [1435f925] Trying to release exclusive lock which does not exist, lock key: '53cfa6c3-ecd6-4796-84cb-5c53d7c2a77fVDS_FENCE'


Expected results:

VDS_FENCE lock should be release only once

Comment 1 Yaniv Kaul 2018-04-30 07:33:29 UTC
Severity?

Comment 2 Petr Matyáš 2018-05-04 15:25:32 UTC
Verified on ovirt-engine-4.2.3.5-0.1.el7.noarch

Comment 3 Sandro Bonazzola 2018-05-10 06:29:07 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.