Bug 1571323 - Create template fail sometimes
Summary: Create template fail sometimes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ravi Nori
QA Contact: Vitalii Yerys
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 14:03 UTC by Michael Burman
Modified: 2018-06-26 08:36 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:36:53 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
engine log (44.93 KB, application/x-gzip)
2018-04-24 14:03 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90723 0 master MERGED engine : Create template fail sometimes 2018-05-10 14:13:51 UTC
oVirt gerrit 91146 0 ovirt-engine-4.2 MERGED engine : Create template fail sometimes 2018-05-14 08:29:28 UTC

Description Michael Burman 2018-04-24 14:03:02 UTC
Created attachment 1426084 [details]
engine log

Description of problem:
Create template fail sometimes 

I have failed to create a template from VM one time on latest 4.2.3.2-0.1.el7
Although it reproduced only one time for me, i was suggested by ahadas to report a bug for infar team.

2018-04-24 15:29:53,451+03 ERROR [org.ovirt.engine.core.bll.tasks.CommandCallbacksPoller] (EE-ManagedThreadFactory-engineScheduled-Thread-92) [8cb0d685-cd01-42d2-89f3-3343
1c432fde] Error invoking callback method 'doPolling' for 'ACTIVE' command '23c5f099-8e4b-4ed8-90ea-8c2dd7d3c506'
2018-04-24 15:29:53,458+03 INFO  [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (EE-ManagedThreadFactory-engine-Thread-415) [8cb0d685-cd01-42d2-89f3-33431c432fde] BaseAsyn
cTask::removeTaskFromDB: Removed task 'a1ace998-b168-4733-aab3-c7d206d03b60' from DataBase
2018-04-24 15:29:53,458+03 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (EE-ManagedThreadFactory-engine-Thread-415) [8cb0d685-cd01-42d2-89f3-33431c432fde] Comm
andAsyncTask::HandleEndActionResult [within thread]: Removing CommandMultiAsyncTasks object for entity '4d66bdb2-bd61-4da0-a9c0-7ee060913860'
2018-04-24 15:29:53,452+03 ERROR [org.ovirt.engine.core.bll.tasks.CommandCallbacksPoller] (EE-ManagedThreadFactory-engineScheduled-Thread-92) [8cb0d685-cd01-42d2-89f3-3343
1c432fde] Exception: java.util.ConcurrentModificationException
        at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:909) [rt.jar:1.8.0_161]
        at java.util.ArrayList$Itr.next(ArrayList.java:859) [rt.jar:1.8.0_161]
        at org.ovirt.engine.core.bll.ChildCommandsCallbackBase.doPolling(ChildCommandsCallbackBase.java:41) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandCallbacksPoller.invokeCallbackMethodsImpl(CommandCallbacksPoller.java:145) [bll.jar:]
        at org.ovirt.engine.core.bll.tasks.CommandCallbacksPoller.invokeCallbackMethods(CommandCallbacksPoller.java:106) [bll.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_161]
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308) [rt.jar:1.8.0_161]
        at org.glassfish.enterprise.concurrent.internal.ManagedScheduledThreadPoolExecutor$ManagedScheduledFutureTask.access$201(ManagedScheduledThreadPoolExecutor.java:38
3) [javax.enterprise.concurrent.jar:1.0.0.redhat-1]
        at org.glassfish.enterprise.concurrent.internal.ManagedScheduledThreadPoolExecutor$ManagedScheduledFutureTask.run(ManagedScheduledThreadPoolExecutor.java:534) [jav
ax.enterprise.concurrent.jar:1.0.0.redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [rt.jar:1.8.0_161]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [rt.jar:1.8.0_161]
        at java.lang.Thread.run(Thread.java:748) [rt.jar:1.8.0_161]
        at org.glassfish.enterprise.concurrent.ManagedThreadFactoryImpl$ManagedThread.run(ManagedThreadFactoryImpl.java:250) [javax.enterprise.concurrent.jar:1.0.0.redhat-
1]
        at org.jboss.as.ee.concurrent.service.ElytronManagedThreadFactory$ElytronManagedThread.run(ElytronManagedThreadFactory.java:78)

2018-04-24 15:29:54,818+03 ERROR [org.ovirt.engine.core.bll.AddVmTemplateCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-62) [8cb0d685-cd01-42d2-89f3-33431c432fde
] Ending command 'org.ovirt.engine.core.bll.AddVmTemplateCommand' with failure.

Version-Release number of selected component (if applicable):
4.2.3.2-0.1.el7

How reproducible:
Reproduced 1 time for me. On second attempt it worked

Steps to Reproduce:
1. Create template from VM

Actual results:
Failed with exception on engine side

Expected results:
Should work

Comment 1 Vitalii Yerys 2018-06-12 10:59:29 UTC
Verified by creating multiple templates from vm on:
rhvm-4.2.4.2-0.1.el7_3.noarch

Comment 2 Sandro Bonazzola 2018-06-26 08:36:53 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.