Bug 157138 - Installation via tftp boot fails after loading the net2stg.img
Installation via tftp boot fails after loading the net2stg.img
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bootparamd (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-07 10:04 EDT by Asif Ayaz
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 16:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asif Ayaz 2005-05-07 10:04:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When We try to install via tftp boot it fails fails after loading the net2stg.img
With the Error:"The anaconda installation tree in that directory does not seem to match your boot media"

Version-Release number of selected component (if applicable):
RHEL3Update 4 

How reproducible:
Always

Steps to Reproduce:
1)We have a HP Netserver with HP Top tools as Remote Console 
2)We need to build this server with RHEL 3.0 (FYI there is no CDROM or Floppy Drive attached) 
3)Installation is being done using tftp boot option of Top Tools.
4)Since the bootdisk.img doesn�t have the network driver we have rebuild the bootdisk.img with the ethernet module.
5)It is booting with the new bootdisk.img and we are able to configure the network card.
6)Next step we specify FTP as the boot method.
7)It starts retreving the files from i386/Redhat/base 
8)product.img retrevial is succesful and the after retreving the net2stg.img file it gives error and comes out

The error is as follows

"The anaconda installation tree in that directory does not seem to match your boot media"

We do not have Floppy Drive or CDROM to use the drvnet.img drivers for installation.


  

Actual Results:  ~ The bootdisk.img doesn�t have the network driver ( intel 82557 )  we have rebuild the bootdisk.img with the ethernet module.
~ It seems like the .img is attempting to access the floppy drive directly and not use the bios routines.

Expected Results:  
The main issue here is that we cannot do a local installation .  There is no way by which we can use a local media to continue the installation. 
Is there some restriction in place not to  modify the original bootdisk.img in redhat WS 3.0 Update 4 release ?




Additional info:

Another Test Done By a Collegue of mine.. and had him say.. 
Basically I take the rhel boot floppy, explode its initrd.img, remove NFS and USB support to make room, poke in nic modules (e1000, eepro100, etc.). and repackage it it'll still stop and prompt you for a driver disk, but you hit 'select drivers' and see the list of modules I manually inserted behind redhat's back they closed that door on me..
Every since rh9 i've used that method to 'force' nic drivers onto a single boot floppy for TopTools.RHEL3u4 just took that away.
Comment 1 Suzanne Hillman 2005-05-12 16:15:09 EDT
Please submit this feature request through your support contact.
Comment 2 Arjan van de Ven 2005-05-19 09:44:35 EDT
looks like you're not using the PXE installer images, which you really want!
(even though they are called "pxe" they are generic network boot images, there
is nothing pxe specific in them). The pxe images have a full set of drivers and
there's no need to mess around with images yourself.
Comment 3 Asif Ayaz 2005-05-20 07:11:54 EDT
Thanks for you update,
This H/W( netserver) doesnt seems to have such an option( pxe Boot)
The top-tools card is one which does the remote boot. It seems like the .img is
attempting to access the floppy drive directly ( which is not available
physically )and doesnt seem to use the bios routines.

Note You need to log in before you can comment on or make changes to this bug.