Bug 1571404 - Review Request: geolite2 - Free IP geolocation databases
Summary: Review Request: geolite2 - Free IP geolocation databases
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 17:27 UTC by Carl George
Modified: 2018-04-27 17:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 02:37:49 UTC
Type: ---
zebob.m: fedora-review+


Attachments (Terms of Use)

Description Carl George 2018-04-24 17:27:58 UTC
Spec URL: http://copr-dist-git.fedorainfracloud.org/cgit/carlwgeorge/geolite2/geolite2.git/tree/geolite2.spec?h=f28
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/carlwgeorge/geolite2/fedora-28-x86_64/00744733-geolite2/geolite2-20180403-1.fc28.src.rpm
COPR: https://copr.fedorainfracloud.org/coprs/carlwgeorge/geolite2/

Description:
GeoLite2 databases are free IP geolocation databases comparable to, but less
accurate than, MaxMind's GeoIP2 databases.  This product includes GeoLite2 data
created by MaxMind, available from http://www.maxmind.com.

Fedora Account System Username: carlwgeorge

Comment 1 Jason Tibbitts 2018-04-24 18:14:07 UTC
I wonder how this is different from the existing GeoIP-GeoLite-data package.

Comment 2 Carl George 2018-04-24 18:55:57 UTC
The existing GeoIP-GeoLite-data package contains the legacy GeoLite databases [1] which have been deprecated and will no longer be updated [2].  This package contains the currently maintained GeoLite2 databases [3].

[1]: https://dev.maxmind.com/geoip/legacy/geolite/
[2]: https://src.fedoraproject.org/rpms/GeoIP-GeoLite-data/c/049fe7b3d8812987944875c0817f7b5a5c7deb57
[3]: https://dev.maxmind.com/geoip/geoip2/geolite2/

Comment 3 Robert-André Mauchin 🐧 2018-04-24 20:29:55 UTC
Have you asked the current maintainer for co-maintainership?

Comment 4 Carl George 2018-04-24 20:41:06 UTC
This package request is directly at the suggestion of Paul (GeoIP-GeoLite-data maintainer) in bug 1570619, comment 5.  I didn't ask to co-maintain GeoIP-GeoLite-data because it will likely never be updated again since the upstream has dropped it.  If you meant asking Paul to co-maintain geolite2 with me, I'm fine with that once it's reviewed, but haven't asked him yet.

Comment 5 Robert-André Mauchin 🐧 2018-04-24 21:19:29 UTC
Package approved.


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "*No copyright* CC by-sa (v4.0)". 5
     files have unknown license. Detailed output of licensecheck in
     /home/bob/packaging/review/geolite2/review-geolite2/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/share/GeoIP(GeoIP-
     GeoLite-data)
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     geolite2-city , geolite2-country
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: geolite2-city-20180403-1.fc29.noarch.rpm
          geolite2-country-20180403-1.fc29.noarch.rpm
          geolite2-20180403-1.fc29.src.rpm
geolite2-city.noarch: W: spelling-error Summary(en_US) geolocation -> echolocation, collocation, allocation
geolite2-city.noarch: W: spelling-error %description -l en_US geolocation -> echolocation, collocation, allocation
geolite2-city.noarch: W: no-documentation
geolite2-country.noarch: W: spelling-error Summary(en_US) geolocation -> echolocation, collocation, allocation
geolite2-country.noarch: W: spelling-error %description -l en_US geolocation -> echolocation, collocation, allocation
geolite2-country.noarch: W: no-documentation
geolite2.src: W: spelling-error Summary(en_US) geolocation -> echolocation, collocation, allocation
geolite2.src: W: spelling-error %description -l en_US geolocation -> echolocation, collocation, allocation
geolite2.src: W: no-%build-section
3 packages and 0 specfiles checked; 0 errors, 9 warnings.

Comment 6 Jason Tibbitts 2018-04-25 00:10:10 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/geolite2

Comment 7 Carl George 2018-04-25 02:37:49 UTC
Thanks everyone!

Comment 8 nucleo 2018-04-27 16:34:52 UTC
Is there reason to not package GeoLite2-ASN?
http://geolite.maxmind.com/download/geoip/database/GeoLite2-ASN.tar.gz

Comment 9 Carl George 2018-04-27 17:51:23 UTC
There's no reason not to package it, but I don't think it should be part of this spec file.  I'm using the release date as the version, and the ASN database is released on a different schedule than the City and Country databases.  From the download page:

> The GeoLite2 Country and City databases are updated on the first Tuesday of each month. The GeoLite2 ASN database is updated every Tuesday.

The content disposition header of the download links confirms this.

Content-Disposition: attachment; filename=GeoLite2-City_20180403.tar.gz
Content-Disposition: attachment; filename=GeoLite2-Country_20180403.tar.gz
Content-Disposition: attachment; filename=GeoLite2-ASN_20180424.tar.gz

A separate geolite2-asn package (starting at version 20180424) would make sense to me, but I don't need it myself so someone else can submit/maintain it.


Note You need to log in before you can comment on or make changes to this bug.