Bug 1571461 - Gnome-control-center must be restarted to see any changes made to user accounts
Summary: Gnome-control-center must be restarted to see any changes made to user accounts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-24 21:00 UTC by Ankur Sinha (FranciscoD)
Modified: 2018-04-29 20:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-29 20:53:35 UTC
Type: Bug


Attachments (Terms of Use)
Screencast showing bug (2.60 MB, application/octet-stream)
2018-04-24 21:00 UTC, Ankur Sinha (FranciscoD)
no flags Details

Description Ankur Sinha (FranciscoD) 2018-04-24 21:00:41 UTC
Created attachment 1426262 [details]
Screencast showing bug

Description of problem:
If one tries to change the avatar of a user, it is not immediately updated in gnome-control-centre. One must close and re-open gnome-control-centre to see the new updated avatar. This appears to be the case for both new and existing user accounts.

Version-Release number of selected component (if applicable):
gnome-control-center-3.28.1-2.fc28.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-control-center
2. Go to details -> users
3. Unlock the dialog, and pick a new avatar from the shown list or an image file

Actual results:
On selecting the new avatar, the gnome-control-center dialog does not show it. One has to close and re-open gnome-control-center to see the new avatar.

Expected results:
It should be updated immediately on selection.

Additional info:
Screencast showing the bug is attached.

Comment 1 Ankur Sinha (FranciscoD) 2018-04-24 21:05:17 UTC
It appears to be any changes to the user accounts. I changed the password for a new account too, and until I'd closed and re-opened gnome-control-center, it wouldn't show the new one (it'd still say "to be set later" etc).

Comment 2 sumantro 2018-04-25 02:45:39 UTC
I can't reproduce this, I am using Fedora-28-20180423.n.0 with Thikpad X220 in a wayland session and gnome-control-center-3.28.1-2.fc28.

Comment 3 Fedora Update System 2018-04-25 08:53:22 UTC
accountsservice-0.6.47-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-250e238b6c

Comment 4 Fedora Update System 2018-04-25 08:53:30 UTC
accountsservice-0.6.47-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c1d39b6bd2

Comment 5 Ankur Sinha (FranciscoD) 2018-04-25 10:21:48 UTC
Thanks for the update. I couldn't reproduce it on a different F28 workstation install, though. So I reckon it's just one of those things :(

Comment 6 Fedora Update System 2018-04-25 19:43:31 UTC
accountsservice-0.6.47-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-250e238b6c

Comment 7 Fedora Update System 2018-04-26 04:52:44 UTC
accountsservice-0.6.47-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c1d39b6bd2

Comment 8 Fedora Update System 2018-04-29 20:53:35 UTC
accountsservice-0.6.47-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.