Bug 1571537 - [trello_FxtSMIUm] The removed corresponding Jenkins job returned when start a new pipeline build in openshift
Summary: [trello_FxtSMIUm] The removed corresponding Jenkins job returned when start ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Corey Daley
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 05:45 UTC by wewang
Modified: 2018-05-09 02:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 02:03:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
jenkins job (58.10 KB, image/png)
2018-05-03 09:05 UTC, wewang
no flags Details

Description wewang 2018-04-25 05:45:56 UTC
Description of problem
Removed the corresponding Jenkins job  returned when delete pipeline build in openshift 

Version-Release number of selected component (if applicable):
brew-pulp-xxxxxx/openshift3/jenkins-2-rhel7 v3.10 ac1e304de673
sync plugin v1.0.14

How reproducible:
always

Steps to Reproduce:
1. Create pipeline bc and other resources
2. Start a pipeline build and wait build to running
   
3. Delete pipeline build in openshift
   $oc delete  build sample-pipeline-1
4. Check the The corresponding Jenkins job in jenkins webconsole, job 1 is deleted
5. Start 2 pipeline build and wait  sample-pipeline-2 to running ,and  sample-pipeline-3 is new
   sample-pipeline-2          JenkinsPipeline                 Running    13    
   sample-pipeline-3          JenkinsPipeline                 New   
 
6. Delete above 2 build in openshift
   $oc delete  build sample-pipeline-3
   $oc delete  build sample-pipeline-2

7. Check the The corresponding Jenkins job in jenkins webconsole
 a.  other corresponding job is deleted, 
 b.  but job 1 related to build sample-pipeline-1 returned, and console output display:
      No such file: /var/lib/jenkins/jobs/wang/jobs/wang-sample-pipeline/builds/1/log
 c.   and a few minute disappeared.

Actual results:
deleted job returned 

Expected results:
deleted job cannot be returned

Comment 1 Corey Daley 2018-04-25 11:01:40 UTC
It sounds like the actual job did not return, just a link was still cached in the view and was showing.  Can you specify what part of the console the link appeared in?

Comment 2 wewang 2018-04-26 01:59:36 UTC
in "build history" of the project xxx/xxxx-sample-pipeline in the console

Comment 3 Ben Parees 2018-05-02 16:16:06 UTC
Corey bump, this is a 3.10 blocker.

Comment 4 Corey Daley 2018-05-02 16:56:52 UTC
Ben, looking at it now.

Comment 5 Corey Daley 2018-05-02 17:27:13 UTC
wewang Was this using the persistent or ephemeral jenkins?  I am not able to recreate the issue.  Can you try refreshing the page manually?

Comment 6 wewang 2018-05-03 09:05:04 UTC
@ Corey Daley  I just use template:https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.yaml to create jenkins resources, yes refreshed page manually , but still exists

Comment 7 wewang 2018-05-03 09:05:55 UTC
Created attachment 1430562 [details]
jenkins job

jenkins job page

Comment 8 wewang 2018-05-03 09:07:27 UTC
I tested it again today, and upload an attachment, pls check it ,thanks

Comment 9 Corey Daley 2018-05-03 14:04:50 UTC
wewang, could you please upload a screenshot of where you are seeing the link to that job?

Comment 11 Corey Daley 2018-05-07 18:03:38 UTC
wewang, 
Could you please upload a screenshot of the page where you are actually seeing the link to the job that you are clicking on in Jenkins?  If you are just refreshing the page for the job and it is saying the job doesn't exist, that is the expected behavior.

Comment 12 wewang 2018-05-08 02:36:09 UTC
as step 7 in c part in comment 1, no matter refresh or not, it'll disappeared a few minutes, maybe it can be accepted, since it will not have build log storage in Jenkins. will close the bug.


Note You need to log in before you can comment on or make changes to this bug.