Bug 1571563 - The VM could not be edited from HighPerformance or Server to Desktop in PPC arch (even if the new create of Desktop is allowed)
Summary: The VM could not be edited from HighPerformance or Server to Desktop in PPC a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.2
Hardware: ppc64
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.6
: 4.2.6
Assignee: Sharon Gratch
QA Contact: Polina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 06:40 UTC by Polina
Modified: 2018-09-03 15:09 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 15:09:27 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
pagranat: testing_plan_complete+
pagranat: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 93311 0 master MERGED webadmin: soundcard enabling value should depend on ppc arch 2018-07-26 14:55:39 UTC
oVirt gerrit 93359 0 ovirt-engine-4.2 MERGED webadmin: soundcard enabling value should depend on ppc arch 2018-07-30 14:44:54 UTC

Description Polina 2018-04-25 06:40:36 UTC
Description of problem:
In PPC arch it is allowed to create new Desktop VM with the following flags are automatically disabled (since it is PPC arch), edit the VM to be High Performance. But it is impossible to edit back  - got an error  "Cannot edit VM. Sound device is not supported on 'ppc64' architecture.”

Version-Release number of selected component (if applicable): rhv-release-4.2.3-2-001.noarch

How reproducible: 100 %

Steps to Reproduce:

1. In PPC arch create new Desktop VM with the following flags are automatically disabled (since it is PPC arch):
    Soundcard enabled
    Enable SPICE file transfer
    Enable SPICE file transfer
2. Edit the VM to be High Performance. Run - ok
3. Try to edit back to Desktop VM

Actual results:
Not allowed with error: "Cannot edit VM. Sound device is not supported on 'ppc64' architecture.”


Expected results: 
Must be allowed editing back from High Performance to the Desktop. 
Or if it must be not allowed, then the create of Desktop must be not allowed also.

Comment 1 Michal Skrivanek 2018-07-16 14:19:10 UTC
not ready for 4.2.5, sharon, any news?

Comment 2 Sharon Gratch 2018-07-24 15:00:08 UTC
(In reply to Michal Skrivanek from comment #1)
> not ready for 4.2.5, sharon, any news?

changeed to 4.2.6.

Comment 3 Sharon Gratch 2018-07-24 15:59:43 UTC
This bug is relevant not only for a scenario of HP type vms changed to desktop type vms in ppc arch, but also relevant for server type changed to desktop type.

The problem was that changing a VM to a desktop type didn't take the arch type in consideration for setting the soundcard flag value.

Comment 4 Polina 2018-08-07 07:27:38 UTC
The bug is verified in rhv-4.2.6-1.
Added polarion cases: 

https://polarion.engineering.redhat.com/polarion/redirect/project/RHEVM3/workitem?id=RHEVM-25783

https://polarion.engineering.redhat.com/polarion/redirect/project/RHEVM3/workitem?id=RHEVM-25784

and automation case in module rhevmtests/compute/sla/high_performance_vm/high_performance_vm_test.py


Note You need to log in before you can comment on or make changes to this bug.