Bug 1571632 - Strange entries in the containers-default-parameters.yaml file
Summary: Strange entries in the containers-default-parameters.yaml file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Honza Pokorny
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 08:53 UTC by Udi
Modified: 2019-01-11 11:49 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:49:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 548329 0 None None None 2018-08-07 09:12:44 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:58 UTC

Description Udi 2018-04-25 08:53:10 UTC
Description of problem:
If you download the containers-default-parameters.yaml file from the plan, you see these 4 entries in the end of it:

  N: 172.16.0.1:8787/rhosp13/openstack-tempest:13.0-18
  e: 172.16.0.1:8787/rhosp13/openstack-tempest:13.0-18
  n: 172.16.0.1:8787/rhosp13/openstack-tempest:13.0-18
  o: 172.16.0.1:8787/rhosp13/openstack-tempest:13.0-18

You don't have these entries when you run the prepare command from the CLI.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Upload a new plan
2. Run: openstack object save <<plan-name>> environments/containers-default-parameters.yaml
3. tail environments/containers-default-parameters.yaml


Actual results:
The last 4 entries "N", "e", "n" and "o" seem like a bug.

Comment 1 Jason E. Rist 2018-04-25 15:38:15 UTC
Does this effect deployments or the containers themselves?

Comment 2 Udi 2018-05-06 08:49:10 UTC
The only way to get a successful deployment is to run the prepare command from the CLI, and overrun the file in the plan because it's completely wrong anyways. See bug https://bugzilla.redhat.com/show_bug.cgi?id=1572245.

Comment 3 Jiri Tomasek 2018-05-09 14:39:28 UTC
Need to investigate further, this bug is probably caused by tripleo-common code which generates the environment

Comment 6 Honza Pokorny 2018-06-08 14:01:54 UTC
This is caused by a missing value in the overcloud_containers.yaml.j2 file in tripleo-common.  Instead of a proper value, it simply has a placeholder of "None".  Python then treats it as a string, and the rest is history.

This has been fixed very recently in upstream master here:

https://review.openstack.org/#/c/548329/

Unfortunately, this patch depends on many other patches related to the containerized undercloud which is scheduled for OSP 14.

Given that this is a cosmetic bug, I suggest that we close it.

Comment 11 Udi 2018-11-05 15:45:37 UTC
Verified: openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 13 errata-xmlrpc 2019-01-11 11:49:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.