Bug 157170 - (IT_73480) Megaraid (megaraid_old) drivers unavailable in RHEL 4.0 + no driver disk
Megaraid (megaraid_old) drivers unavailable in RHEL 4.0 + no driver disk
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Perkins
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-08 00:15 EDT by Richard L. Goerwitz III
Modified: 2007-11-30 17:07 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 18:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard L. Goerwitz III 2005-05-08 00:15:24 EDT
A megaraid (megaraid_old) driver disk is needed for RHEL 4.0.

Megaraid_mm and megaraid_mbox drivers have been found to lack support for many
older LSI controllers, as has been noted (and complained about) in a number of
bug reports (e.g., the LSI 467 - Dell Perc 2/DC).

This bug merely records the fact that although the megaraid (megaraid_old)
driver is present in the 2.6 kernel series (and in some cases actually works) it
is not available on the RHEL 4.0 install disks.  Nor is any driver disk
available that would allow the megaraid driver to be loaded.

As a result (as I'm sure RedHat has been made aware) there are a lot of
customers out here who were using old Dells as test boxes, who can't use RHEL
4.0 because it loads megaraid_mbox drivers - which seem to work fine with the
Perc 2/DC controller, but which cause the install to bomb when logical drives
aren't detected.

A megaraid (megaraid_old) driver disk would, I gather, be very much appreciated.

See bug ID 138590, where some kind soul actually made such a driver disk
available to FC3 users.  That bug ID is cited liberally around the net.  You can
easily Google for it.  Just search for "138590".  Why is it so liberally cited?
 Because a lot of people are still running machines with LSI 467 controllers in
them.  Linux is supposedly great at running on not only high-end hardware but
also low-cost legacy hardware, and people are a bit surprised when they turn up
cases where widely used, but old hardware doesn't work.
Comment 2 Mike Timonin 2005-05-19 10:50:11 EDT
I've tried to create adriver disk myself, but encountered some problems
First of all it was hard to find modules.pcimap and pci.ids files, but some
digging and it seemes solved

The main problem is in module itself

On another machine with RHEL4 I've compiled megaraid.ko with smp and without it
also. Kernelversions are 2.6.9-5.EL and 2.6.9-5.ELsmp
They fail with megaraid: disagrees about version of symbol struct_module
Then I've tried with 2.6.9-5 but it also failed.

It seems to me that kernelversion during the install is 2.6.9-5.EL, is it wrong?

Maybe you guys could do this module or (what would be great) the complete driver
disk. 

Thanks in advance.
Comment 3 Jason 2005-06-14 15:11:38 EDT
I have HP LH4 and LC2000 NetServers that have HP NetRaid cards (1si, 3m, 3si,
etc) and RHEL4U1 still does not have support for the megaraid (not the
megaraid_mbox) driver.
Comment 4 Tom Coughlan 2005-07-28 18:18:17 EDT
From the RHEL 4 release notes (for original release, and U1):

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/release-notes/as-x86/RELEASE-NOTES-U1-x86-en.html

    * The kernel shipped with Red Hat Enterprise Linux 4 Update 1 includes the
new megaraid_mbox driver from LSI Logic, which replaces the megaraid driver. The
megaraid_mbox driver has an improved design, is compatible with the 2.6 kernel,
and includes support for the latest hardware. However, megaraid_mbox does not
support some of the older hardware that was supported by the megaraid driver.

      Adapters with the following PCI vendor ID and device ID pairs are not
supported by the megaraid_mbox driver:


vendor, device

0x101E, 0x9010
0x101E, 0x9060
0x8086, 0x1960

      The lspci -n command can be used to display the IDs for adapters installed
in a particular machine. Products with these IDs are known by (but not limited
to) the following model names: 

    *Broadcom 5820
    *Dell PERC (dual-channel fast/wide SCSI) RAID controller
    *Dell PERC2/SC (single-channel Ultra SCSI) RAID controller
    *Dell PERC2/DC (dual-channel Ultra SCSI) RAID controller
    *Dell CERC (four-channel ATA/100) RAID controller
    *DRAC 1
    *MegaRAID 428
    *MegaRAID 466
    *MegaRAID Express 500
    *HP NetRAID 3Si and 1M 

Note

Both Dell and LSI Logic have indicated that they no longer support these models
in the 2.6 kernel. As a result, these adapters are no longer supported in Red
Hat Enterprise Linux 4 Update 1.

======

I agree, this stinks, but there is not much we can do. The legacy driver and the
current driver have overlapping support, so we can not turn both on. The legacy
driver has also not received any recent maintenance.  

Comment 5 Simon Matter 2005-07-29 01:29:08 EDT
> I agree, this stinks, but there is not much we can do. The legacy driver
> and the current driver have overlapping support, so we can not turn both
> on.

I'm wondering why both drivers are turned on in FC4 and why it should not be
possible in RHEL4? Looking at this page it seems that both drivers can coexist
fine
http://www.tuxyturvy.com/blog/index.php?/archives/4-Installing-RHEL4-on-Systems-with-Legacy-Megaraid-Drivers.html
without modifying the RHEL4 kernel. As a customer of both, DELL and RedHat, I'm
not very happy with the situation.

Note You need to log in before you can comment on or make changes to this bug.