Bug 1571726 - [svcat] `svcat describe class ` with optional flags `--traverse` result of plans are duplicated
Summary: [svcat] `svcat describe class ` with optional flags `--traverse` result of p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Jay Boyd
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 10:15 UTC by sunzhaohua
Modified: 2018-07-30 19:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
closed in current release
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:14:10 UTC

Description sunzhaohua 2018-04-25 10:15:37 UTC
Description of problem:
[svcat] `svcat describe class ` with optional flags `--traverse`  result of plans are duplicated

Version-Release number of selected component (if applicable):
svcat:
client: v3.10.0-0.27.0;Upstream:v0.1.13
server: v1.10.0+b81c8f8

How reproducible:
Always

Steps to Reproduce:
1. Deploy service-catalog and ASB in OCP cluster.
2. #svcat describe class -h
3. #svcat describe class rh-postgresql-apb --traverse

Actual results:
The help information show " -t, --traverse   Whether or not to traverse from plan -> class -> broker"
In fact, the result is class -> broker >plan and the plan part included in class part already.

$ svcat describe class rh-postgresql-apb --traverse
  Name:          rh-postgresql-apb                  
  Description:   SCL PostgreSQL apb implementation  
  UUID:          d5915e05b253df421efe6e41fb6a66ba   
  Status:        Active                             
  Tags:          database, postgresql               
  Broker:        ansible-service-broker             

Plans:
  NAME            DESCRIPTION            
+------+--------------------------------+
  prod   A single DB server with         
         persistent storage              
  dev    A single DB server with no      
         storage                         

Broker:
  Name:     ansible-service-broker  
  Status:   Ready                   

Plans:
  NAME            DESCRIPTION            
+------+--------------------------------+
  prod   A single DB server with         
         persistent storage              
  dev     A single DB server with no      
         storage    

Expected results:
the result should keep in order with the help information and no duplication.

Additional info:

Comment 1 Jay Boyd 2018-05-18 21:15:02 UTC
fixed upstream with https://github.com/kubernetes-incubator/service-catalog/pull/2026

Please note that --traverse has been removed.  

Plans will always be shown when you do svcat describe class XX


This is in v0.1.19 of upstream service catalog and will be picked up with OpenShift builds done AFTER May 18 17:00 US Eastern.  I believe this will be ​3.10.0-0.48.0 or newer

Comment 2 sunzhaohua 2018-05-22 10:10:15 UTC
 image is ready, change it to ON-QA

Comment 3 sunzhaohua 2018-05-22 10:11:25 UTC
Verified.

[root@ip-172-18-12-36 ~]# svcat version
client: v3.10.0-0.50.0;Upstream:v0.1.19
server: v1.10.0+b81c8f8

[root@ip-172-18-12-36 ~]# svcat describe class -h
Show details of a specific class

Usage:
  svcat describe class NAME [flags]

Aliases:
  class, classes, cl


Examples:

  svcat describe class mysqldb
  svcat describe class -uuid 997b8372-8dac-40ac-ae65-758b4a5075a5


Flags:
  -u, --uuid   Whether or not to get the class by UUID (the default is by name)

Global Flags:
      --context string      name of the kubeconfig context to use.
      --kubeconfig string   path to kubeconfig file. Overrides $KUBECONFIG
      --logtostderr         log to standard error instead of files (default false)
  -v, --v Level             log level for V logs


[root@ip-172-18-12-36 ~]# svcat describe class rh-mysql-apb
  Name:          rh-mysql-apb                      
  Description:   Software Collections MySQL APB    
  UUID:          73ead67495322cc462794387fa9884f5  
  Status:        Active                            
  Tags:          database, mysql                   
  Broker:        ansible-service-broker            

Plans:
  NAME            DESCRIPTION            
+------+--------------------------------+
  prod   A MySQL server with persistent  
         storage                         
  dev    A MySQL server with ephemeral   
         storage

Comment 6 errata-xmlrpc 2018-07-30 19:13:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.