Bug 1571729 - Unable to import "Red Hat Atomic Image for RHEV" on RHV environment [NEEDINFO]
Summary: Unable to import "Red Hat Atomic Image for RHEV" on RHV environment
Keywords:
Status: CLOSED DUPLICATE of bug 1622075
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1186913
TreeView+ depends on / blocked
 
Reported: 2018-04-25 10:18 UTC by Miguel Martin
Modified: 2020-03-18 01:56 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-18 01:56:32 UTC
Target Upstream Version:
mkalinin: needinfo? (mavital)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3459921 None None None 2019-10-07 15:56:08 UTC

Description Miguel Martin 2018-04-25 10:18:12 UTC
Description of problem:

Importing "Red Hat Atomic Image for RHEV" in a RHEV environment fails.

Version-Release number of selected component (if applicable):
rhel-atomic-rhevm-7.5.0-8.x86_64.rhevm.ova

How reproducible:
Always

Steps to Reproduce:
1. Download the from customer portal at:
https://access.redhat.com/downloads/content/271/ver=/rhel---7/7.5.0/x86_64/product-software
2. Try to import the ova in an RHV installation

Actual results:
The import fails


Expected results:
The import succeed

Additional info:

The following error appears on vdsm.log file:
~~~
2018-04-24 12:28:42,129-0400 ERROR (jsonrpc/5) [jsonrpc.JsonRpcServer] Internal server error (__init__:577)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yajsonrpc/__init__.py", line 572, in _handle_request
    res = method(**params)
  File "/usr/lib/python2.7/site-packages/vdsm/rpc/Bridge.py", line 202, in _dynamicMethod
    result = fn(*methodArgs)
  File "/usr/share/vdsm/API.py", line 1537, in getExternalVmFromOva
    return v2v.get_ova_info(ova_path)
  File "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 231, in get_ova_info
    _add_general_ovf_info(vm, root, ns, ova_path)
  File "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 1263, in _add_general_ovf_info
    raise V2VError('Error parsing ovf information: no memory size')
V2VError: Error parsing ovf information: no memory size
2018-04-24 12:28:42,374-0400 INFO  (jsonrpc/5) [jsonrpc.JsonRpcServer] RPC call Host.getExternalVmFromOva failed (error -32603) in 25.71 seconds (__init__:539)
~~~

Comment 4 Peter Larsen 2019-02-19 22:02:27 UTC
February 2019 - this is still an issue. Can this please be fixed?

Comment 14 Derrick Ornelas 2020-03-18 01:56:32 UTC
Closing this as a duplicate of Bug 1622075.  Based on this bug and the availability of the qcow2 image, the decision was made in November to no longer create and ship the RHV OVA image for RHEL Atomic Host.

*** This bug has been marked as a duplicate of bug 1622075 ***


Note You need to log in before you can comment on or make changes to this bug.