Bug 1571798 - Node 0 deployment fails over FC. TypeError: 'NoneType' object is not iterable.
Summary: Node 0 deployment fails over FC. TypeError: 'NoneType' object is not iterable.
Keywords:
Status: CLOSED DUPLICATE of bug 1571467
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Ido Rosenzwig
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 12:41 UTC by Nikolai Sednev
Modified: 2018-04-25 13:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-25 13:04:04 UTC
oVirt Team: Integration
nsednev: planning_ack?
nsednev: devel_ack?
nsednev: testing_ack?


Attachments (Terms of Use)
sosreport from host (9.46 MB, application/x-xz)
2018-04-25 12:41 UTC, Nikolai Sednev
no flags Details
engine logs (9.08 MB, application/x-xz)
2018-04-25 12:44 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2018-04-25 12:41:49 UTC
Created attachment 1426618 [details]
sosreport from host

Description of problem:
Node 0 deployment fails over FC.
TypeError: 'NoneType' object is not iterable.

[ INFO  ] TASK [Add Fibre Channel storage domain]
[ ERROR ] TypeError: 'NoneType' object is not iterable
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "'NoneType' object is not iterable"}
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: 


See here for deployment flow:
http://pastebin.test.redhat.com/582127

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.18-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch
rhvm-appliance-4.2-20180420.0.el7.noarch
Red Hat Enterprise Linux Server release 7.5 (Maipo)
Linux 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
100%

Steps to Reproduce:
1.Deploy Node 0 using CLI over FC.

Actual results:
Deployment fails.

Expected results:
Deployment should succeed.

Additional info:
Sosreport from host and engine attached.
The same deployment using CLI and vintage is working fine over FC.

Comment 1 Nikolai Sednev 2018-04-25 12:44:05 UTC
Created attachment 1426619 [details]
engine logs

Comment 2 Yaniv Kaul 2018-04-25 13:04:04 UTC
Dup of https://bugzilla.redhat.com/show_bug.cgi?id=1571467 .

*** This bug has been marked as a duplicate of bug 1571467 ***


Note You need to log in before you can comment on or make changes to this bug.