Bug 1571805 - [UPDATE/UPGRADE/FFU]: 'openstack overcloud update/upgrade/ffwd-upgrade run' fails if stack is different then overcloud
Summary: [UPDATE/UPGRADE/FFU]: 'openstack overcloud update/upgrade/ffwd-upgrade run' f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-25 12:53 UTC by Chris Janiszewski
Modified: 2018-06-27 13:55 UTC (History)
11 users (show)

Fixed In Version: python-tripleoclient-9.2.1-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 566435 None None None 2018-05-05 13:47:49 UTC
Launchpad 1767379 None None None 2018-04-27 14:06:13 UTC
OpenStack gerrit 564772 None master: MERGED python-tripleoclient: Add --stack to update, upgrade and ffwd-upgrade 'run' CLI. (I0499eabc5c6f15cb32b2471c86245578c71a2... 2018-05-07 14:54:54 UTC
OpenStack gerrit 566435 None stable/queens: MERGED python-tripleoclient: Add --stack to update, upgrade and ffwd-upgrade 'run' CLI. (I0499eabc5c6f15cb32b2471c86245578c71a2... 2018-05-07 14:57:03 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:00 UTC

Description Chris Janiszewski 2018-04-25 12:53:26 UTC
Description of problem:
Running FFU from OSP10 -> OSP13
When deployed overcloud, specified the stack name to be something different. 

Version-Release number of selected component (if applicable):
OSP10 -> OSP13

How reproducible:
every time

Steps to Reproduce:
1. Deploy OSP10 with --stack different_name
2. Perform FFU upgrade to OSP13 with openstack overcloud ffwd-upgrade run
3.

Actual results:
(undercloud) [stack@undercloud ~]$ openstack overcloud ffwd-upgrade run
Started Mistral Workflow tripleo.package_update.v1.update_nodes. Execution ID: 46caaa3b-bf7f-4d7b-96be-73cab0ddedb7
Waiting for messages on queue 'ffwdupgrade' with no timeout.
[u'Using /tmp/ansible-mistral-actionW8vHZ6/ansible.cfg as config file',
u' [WARNING]: Skipping unexpected key (hostvars) in group (_meta), only "vars",',
u'"children" and "hosts" are valid',
u' [WARNING]: Could not match supplied host pattern, ignoring: overcloud',
u'',
u'PLAY [overcloud] ***************************************************************',
u'skipping: no hosts matched',
u'',
u'PLAY RECAP *********************************************************************',
u'']
'headers'

Expected results:
things should start upgrading

Additional info:
There is a workaround:
tripleo-ansible-inventory --stack chrisj-ffu --static-yaml-inventory overcloud.yml
openstack overcloud ffwd-upgrade run --static-inventory overcloud.yml

Comment 1 Chris Janiszewski 2018-04-25 13:34:21 UTC
looks like similar problem occurs later in the process with:
openstack overcloud upgrade run --roles Controller --skip-tags validation

Comment 2 Jiri Stransky 2018-04-27 13:44:13 UTC
This likely affects minor and major upgrade too, changing title.

Comment 3 Carlos Camacho 2018-05-07 07:20:45 UTC
Hey Mike, Maria we need this as blocker, the fix is merged upstream, and waiting for the downstream patch/ package.

Comment 4 Carlos Camacho 2018-05-07 07:23:07 UTC
Waiting for queens to merge

Comment 5 Carlos Camacho 2018-05-07 09:56:24 UTC
Queens patch merged, waiting for blocker flag

Comment 8 Carlos Camacho 2018-05-07 15:10:46 UTC
Hey Maria, it affects all Minor updates, major upgrades and fast forward upgrades.

Comment 15 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.